CVE-2026-73842 OpenChoreo: cluster-gateway internal proxy performs no caller authentication and is not read-only — data-plane Secret disclosure and arbitrary Kubernetes mutation
Unauthenticated access to internal proxy endpoints allows attackers to read Kubernetes Secrets and execute arbitrary commands across data planes.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Local or same network only
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-73842?
CVE-2026-73842 is a critical missing authorization vulnerability in openchoreo, published on 13 Aug 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Official description
OpenChoreo is a complete, open-source developer platform for Kubernetes. Prior to 1.0.3, 1.1.3, and 1.2.0-rc.2, internal/cluster-gateway/server.go exposed /api/proxy/, /api/exec/, and /api/wirelogs/ on an internal listener without requiring a client certificate or token, allowing any network-reachable caller to read tenant Kubernetes Secrets, mutate workloads, and execute commands across connected data planes. This issue is fixed in versions 1.0.3, 1.1.3, and 1.2.0-rc.2.
Which versions are affected by CVE-2026-73842?
7 open source packages ship an affected version, including github.com/openchoreo/openchoreo.
| Package | Affected | Fixed in |
|---|---|---|
github.com/openchoreo/openchoreo Go | All versions | 1.0.3, 1.1.3, 1.2.0 |
github.com/openchoreo/openchoreo Go | All versions | 1.0.3 |
github.com/openchoreo/openchoreo Go | All versions | 1.0.3 |
github.com/openchoreo/openchoreo Go | From 1.1.0 | 1.1.3 |
github.com/openchoreo/openchoreo Go | From 1.1.0 | 1.1.3 |
github.com/openchoreo/openchoreo Go | From 1.2.0-rc.1 | 1.2.0 |
1 more packages
github.com/openchoreo/openchoreo Go | From 1.2.0-rc.1 | 1.2.0 |
How do I fix CVE-2026-73842?
Upgrade github.com/openchoreo/openchoreo to a fixed version for your release line: 1.0.3, 1.1.3 or 1.2.0.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2026-73842 being exploited?
There is no known exploitation of CVE-2026-73842 in the wild and no public exploit code.
Sources
Also known as GHSA-rh53-xvx2-j327, GO-2026-6428.