CVE-2026-7387 Mattermost group syncable endpoints allow privilege escalation via scheme_admin
Attackers with group-link permissions can escalate to team or channel admin by bypassing role-management checks on group syncable endpoints.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-7387?
CVE-2026-7387 is a high-severity vulnerability in Mattermost Mattermost Server, published on 12 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Mattermost versions 11.6.x <= 11.6.1, 11.5.x <= 11.5.4, 10.11.x <= 10.11.15, 10.11.x <= 10.11.16 Mattermost fails to require role-management authorization when setting the scheme_admin flag on group syncable link and patch endpoints, which allows a user with group-link permissions to escalate themselves and group members to team or channel admin via crafted API requests.. Mattermost Advisory ID: MMSA-2026-00665
Weakness: CWE-863
Which versions are affected by CVE-2026-7387?
12 open source packages ship an affected version, including github.com/mattermost/mattermost-server, github.com/mattermost/mattermost-server/v5 and github.com/mattermost/mattermost-server/v6. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/mattermost/mattermost-server Go | From 10.11.0 | 10.11.17 |
github.com/mattermost/mattermost-server Go | From 10.11.0 | 10.11.17 |
github.com/mattermost/mattermost-server Go | From 10.11.0+incompatible | 10.11.17+incompatible, 11.5.5+incompatible, 11.6.1+incompatible |
github.com/mattermost/mattermost-server Go | From 11.5.0 | 11.5.5 |
github.com/mattermost/mattermost-server Go | From 11.5.0 | 11.5.5 |
github.com/mattermost/mattermost-server Go | From 11.6.0 | 11.6.1 |
6 more packages
github.com/mattermost/mattermost-server Go | From 11.6.0 | 11.6.1 |
github.com/mattermost/mattermost-server/v5 Go | All versions | None |
github.com/mattermost/mattermost-server/v6 Go | All versions | None |
github.com/mattermost/mattermost/server/v8 Go | From 8.0.0-20250731163400-5b955468ea1e | 8.0.0-20260506065351-202d125afa87 |
github.com/mattermost/mattermost/server/v8 Go | From 8.0.0-20250731163400-5b955468ea1e | 8.0.0-20260506065351-202d125afa87 |
github.com/mattermost/mattermost/server/v8 Go | From 8.0.0-20250731163400-5b955468ea1e | 8.0.0-20260506065351-202d125afa87 |
Products include Mattermost Mattermost Server.
How do I fix CVE-2026-7387?
Upgrade github.com/mattermost/mattermost-server to a fixed version for your release line: 10.11.17, 10.11.17+incompatible, 11.5.5+incompatible or 11.6.1+incompatible.
Is CVE-2026-7387 being exploited?
There is no known exploitation of CVE-2026-7387 in the wild and no public exploit code.
Other vulnerabilities in Mattermost Mattermost Server
- CVE-2025-12419 Account takeover on OAuth/OpenID-enabled servers
- CVE-2025-12421 Account Takeover via Code Exchange Endpoint
- CVE-2025-4981 Path Traversal Leading to RCE by Any Authenticated Mattermost User
- CVE-2025-20051 Arbitrary file read via block duplication in Mattermost Boards
- CVE-2025-25279 Arbitrary file read in Mattermost Boards via import & export board archive
Sources
Also known as GHSA-6hxm-w4hv-vgvw, GO-2026-6280.