# CVE-2026-74048: Apache Tomcat: OpenSSL-FFM FIPS failure does not prevent start-up


- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 20 Oct 2026
- **Updated:** 29 Oct 2026
- **Also known as:** BIT-tomcat-2026-74048, DEBIAN-CVE-2026-74048, GHSA-38jj-69cp-9wgc, UBUNTU-CVE-2026-74048

## What is CVE-2026-74048?

CVE-2026-74048 is a medium-severity vulnerability in Apache Tomcat, published on 20 Oct 2026. 

### Official description

Not Failing Securely ('Failing Open') vulnerability in Apache Tomcat. If the OpenSSLLifecycleListener is configured to use FIPS mode but FIPS activation fails, Tomcat logs and error but continues to use JSSE in non-FIPS mode with the provided configuration.

This issue affects Apache Tomcat: from 11.0.0-M14 through 11.0.26, from 10.1.22 through 10.1.60, from 9.0.92 through 9.0.122.

Users are recommended to upgrade to version 11.0.27, 10.1.61 or 9.0.123, which fix the issue.

Weakness: CWE-636 (Not Failing Securely)

## Which versions are affected by CVE-2026-74048?

1 open source package ship an affected version, including tomcat.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `tomcat` | Bitnami | From 9.0.92 | 9.0.123, 10.1.61, 11.0.27 |

## How do I fix CVE-2026-74048?

Upgrade tomcat to a fixed version for your release line: 9.0.123, 10.1.61 or 11.0.27.

## Is CVE-2026-74048 being exploited?

There is no known exploitation of CVE-2026-74048 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-74048 and fix it if it is affected.

What it is: CVE-2026-74048 is a medium-severity vulnerability in Apache Tomcat, published on 20 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-74048 in the wild and no public exploit code.

Affected packages and fixed versions:
- tomcat (Bitnami): affected from 9.0.92; fixed in 9.0.123, 10.1.61, 11.0.27

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-74048/ (Markdown: https://insights.sbomify.com/CVE-2026-74048/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-74048
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-74048
- OSV: https://osv.dev/vulnerability/CVE-2026-74048

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-74048/
Summaries are generated and may contain mistakes; the official description above is the record.
