# CVE-2026-74049: Apache Tomcat: Jasper JSTL <c:redirect> plug-in implementation omits page abort (SKIP_PAGE)


- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 20 Oct 2026
- **Updated:** 29 Oct 2026
- **Also known as:** BIT-tomcat-2026-74049, DEBIAN-CVE-2026-74049, GHSA-2hg3-hfj5-cq2f, UBUNTU-CVE-2026-74049

## What is CVE-2026-74049?

CVE-2026-74049 is a medium-severity vulnerability in Apache Tomcat, published on 20 Oct 2026. 

### Official description

Execution After Redirect (EAR) vulnerability in Apache Tomcat.

This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.26, from 10.1.0-M1 through 10.1.60, from 9.0.0.M1 through 9.0.122.

The following versions were EOL at the time the CVE was created but are 
known to be affected: from 8.5.0 through 8.5.100, from 7.0.0 through 7.0.109. Other unsupported versions may also be affected.

Users are recommended to upgrade to version 11.0.27, 10.1.61, 9.0.123, which fixes the issue.

Weakness: CWE-698 (Execution After Redirect (EAR))

## Which versions are affected by CVE-2026-74049?

1 open source package ship an affected version, including tomcat.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `tomcat` | Bitnami | From 7.0.0 | 9.0.123, 10.1.61, 11.0.27 |

## How do I fix CVE-2026-74049?

Upgrade tomcat to a fixed version for your release line: 9.0.123, 10.1.61 or 11.0.27.

## Is CVE-2026-74049 being exploited?

There is no known exploitation of CVE-2026-74049 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-74049 and fix it if it is affected.

What it is: CVE-2026-74049 is a medium-severity vulnerability in Apache Tomcat, published on 20 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-74049 in the wild and no public exploit code.

Affected packages and fixed versions:
- tomcat (Bitnami): affected from 7.0.0; fixed in 9.0.123, 10.1.61, 11.0.27

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-74049/ (Markdown: https://insights.sbomify.com/CVE-2026-74049/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-74049
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-74049
- OSV: https://osv.dev/vulnerability/CVE-2026-74049

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-74049/
Summaries are generated and may contain mistakes; the official description above is the record.
