# CVE-2026-7411: Eclipse BaSyx Java Server SDK vulnerable to Path Traversal

> Unauthenticated attackers can exploit path traversal in the Submodel HTTP API to write arbitrary files, leading to remote code execution and system compromise.

- **Severity:** Critical 10.0 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 May 2026
- **Updated:** 6 May 2026
- **Also known as:** GHSA-8gpm-h2mh-36qc

## What is CVE-2026-7411?

CVE-2026-7411 is a critical path traversal vulnerability in Eclipse BaSyx, published on 5 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In Eclipse BaSyx Java Server SDK versions prior to 2.0.0-milestone-10, inadequate path normalization in the Submodel HTTP API allows an unauthenticated remote attacker to perform a path traversal attack. By supplying a maliciously crafted fileName parameter during a file upload operation, an attacker can bypass intended storage boundaries and write arbitrary files to any location on the host filesystem accessible by the Java process. This can lead to Remote Code Execution (RCE) and complete system compromise.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-7411?

2 open source packages ship an affected version, including org.eclipse.basyx:basyx.sdk.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.eclipse.basyx:basyx.sdk` | Maven | All versions | 2.0.0-milestone-10 |
| `org.eclipse.basyx:basyx.sdk` | Maven | All versions | 2.0.0-milestone-10 |

## How do I fix CVE-2026-7411?

Upgrade org.eclipse.basyx:basyx.sdk to 2.0.0-milestone-10 or later.

## Is CVE-2026-7411 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-7411 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-7411 and fix it if it is affected.

What it is: CVE-2026-7411 is a critical path traversal vulnerability in Eclipse BaSyx, published on 5 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-7411 exists.

Affected packages and fixed versions:
- org.eclipse.basyx:basyx.sdk (Maven): affected all versions; fixed in 2.0.0-milestone-10
- org.eclipse.basyx:basyx.sdk (Maven): affected all versions; fixed in 2.0.0-milestone-10

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-7411/ (Markdown: https://insights.sbomify.com/CVE-2026-7411/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-7411
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-7411
- OSV: https://osv.dev/vulnerability/CVE-2026-7411

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-7411/
Summaries are generated and may contain mistakes; the official description above is the record.
