CVE-2026-7427 Allocation of Resources Without Limits or Throttling in GitLab

Medium 5.3 Published Updated

An unauthenticated attacker can cause a denial of service in GitLab due to improper input validation and lack of resource limits.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-7427?

CVE-2026-7427 is a medium-severity denial of service vulnerability in Gitlab Gitlab, published on 12 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

GitLab has remediated an issue in GitLab CE/EE affecting all versions from 18.5 before 19.0.6, 19.1 before 19.1.4, and 19.2 before 19.2.2 that under certain conditions could have allowed an unauthenticated user to cause a denial of service due to improper input validation.

Weakness: CWE-770

Which versions are affected by CVE-2026-7427?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 18.5.019.0.6, 19.1.4, 19.2.2

Products include Gitlab Gitlab.

How do I fix CVE-2026-7427?

Upgrade gitlab to a fixed version for your release line: 19.0.6, 19.1.4 or 19.2.2.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2026-7427 being exploited?

There is no known exploitation of CVE-2026-7427 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2026-7427, GHSA-mrwr-f6g8-28q2, MINI-69h7-6ph4-xjpc, MINI-8g9w-9h5g-v73m.

Is CVE-2026-7427 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free