{"answers":{"affected":"2 open source packages ship an affected version, including mcp-server-semgrep.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-7446 exists.","fix":"Upgrade mcp-server-semgrep to 1.0.1 or later.","what":"CVE-2026-7446 is a medium-severity command injection vulnerability in VetCoders mcp-server-semgrep, published on 30 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-7446 and fix it if it is affected.\n\nWhat it is: CVE-2026-7446 is a medium-severity command injection vulnerability in VetCoders mcp-server-semgrep, published on 30 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-7446 exists.\n\nAffected packages and fixed versions:\n- mcp-server-semgrep (npm): affected all versions; fixed in 1.0.1\n- mcp-server-semgrep (npm): affected all versions; fixed in 1.0.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-7446/ (Markdown: https://insights.sbomify.com/CVE-2026-7446/index.md)","id":"CVE-2026-7446","markdown":"https://insights.sbomify.com/CVE-2026-7446/index.md","name":"CVE-2026-7446","record":{"aliases":["GHSA-86hp-qxqp-w9wv"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Semgrep MCP server","requires_auth":"none","summary":"Remote attackers can execute arbitrary OS commands via the create_rule function in the VetCoders mcp-server-semgrep library.","user_interaction":"not_required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[],"cvss":{"score":6.9,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:P","version":"4.0"},"cwes":[{"id":"CWE-78","name":"Improper Neutralization of Special Elements used in an OS Command"},{"id":"CWE-77","name":"Improper Neutralization of Special Elements used in a Command"}],"description":"A vulnerability was detected in VetCoders mcp-server-semgrep 1.0.0. This affects the function analyze_results/filter_results/export_results/compare_results/scan_directory/create_rule of the file src/index.ts of the component MCP Interface. The manipulation of the argument ID results in os command injection. The attack can be executed remotely. The exploit is now public and may be used. Upgrading to version 1.0.1 is able to mitigate this issue. The patch is identified as 141335da044e53c3f5b315e0386e01238405b771. It is advisable to upgrade the affected component.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"VetCoders mcp-server-semgrep MCP index.ts create_rule os command injection","id":"CVE-2026-7446","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"command_injection","year":"2026"},"n_packages":2,"n_references":8,"next":{"headline":"SourceCodester Pet Grooming Management Software update_customer.php sql injection","id":"CVE-2026-7447"},"packages":[{"ecosystem":"npm","fixed":["1.0.1"],"introduced":["0"],"last_affected":[],"package":"mcp-server-semgrep","purl":null,"source":"GHSA-86hp-qxqp-w9wv"},{"ecosystem":"npm","fixed":["1.0.1"],"introduced":["0"],"last_affected":[],"package":"mcp-server-semgrep","purl":"pkg:npm/mcp-server-semgrep","source":"GHSA-86hp-qxqp-w9wv"}],"prev":{"headline":"ZachHandley ZMCPTools MCP Log Resource ResourceManager.ts path traversal","id":"CVE-2026-7445"},"products":["mcp-server-semgrep"],"published":"2026-04-30","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-04-30","vendors":["VetCoders"]},"summary":"Remote attackers can execute arbitrary OS commands via the create_rule function in the VetCoders mcp-server-semgrep library.","url":"https://insights.sbomify.com/CVE-2026-7446/"}