# CVE-2026-7446: VetCoders mcp-server-semgrep MCP index.ts create_rule os command injection

> Remote attackers can execute arbitrary OS commands via the create_rule function in the VetCoders mcp-server-semgrep library.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 30 Apr 2026
- **Updated:** 30 Apr 2026
- **Also known as:** GHSA-86hp-qxqp-w9wv

## What is CVE-2026-7446?

CVE-2026-7446 is a medium-severity command injection vulnerability in VetCoders mcp-server-semgrep, published on 30 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A vulnerability was detected in VetCoders mcp-server-semgrep 1.0.0. This affects the function analyze_results/filter_results/export_results/compare_results/scan_directory/create_rule of the file src/index.ts of the component MCP Interface. The manipulation of the argument ID results in os command injection. The attack can be executed remotely. The exploit is now public and may be used. Upgrading to version 1.0.1 is able to mitigate this issue. The patch is identified as 141335da044e53c3f5b315e0386e01238405b771. It is advisable to upgrade the affected component.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command), CWE-77 (Improper Neutralization of Special Elements used in a Command)

## Which versions are affected by CVE-2026-7446?

2 open source packages ship an affected version, including mcp-server-semgrep.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mcp-server-semgrep` | npm | All versions | 1.0.1 |
| `mcp-server-semgrep` | npm | All versions | 1.0.1 |

## How do I fix CVE-2026-7446?

Upgrade mcp-server-semgrep to 1.0.1 or later.

## Is CVE-2026-7446 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-7446 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-7446 and fix it if it is affected.

What it is: CVE-2026-7446 is a medium-severity command injection vulnerability in VetCoders mcp-server-semgrep, published on 30 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-7446 exists.

Affected packages and fixed versions:
- mcp-server-semgrep (npm): affected all versions; fixed in 1.0.1
- mcp-server-semgrep (npm): affected all versions; fixed in 1.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-7446/ (Markdown: https://insights.sbomify.com/CVE-2026-7446/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-7446
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-7446
- OSV: https://osv.dev/vulnerability/CVE-2026-7446

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-7446/
Summaries are generated and may contain mistakes; the official description above is the record.
