CVE-2026-7471 Server-Side Request Forgery (SSRF) in GitLab

Low 3.5 Published Updated

Authenticated users with virtual registry control can exploit improper validation to access internal hosts via Server-Side Request Forgery.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-7471?

CVE-2026-7471 is a low-severity server-side request forgery vulnerability in Gitlab Gitlab, published on 14 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

GitLab has remediated an issue in GitLab EE affecting all versions from 18.8 before 18.9.7, 18.10 before 18.10.6, and 18.11 before 18.11.3 that could have allowed an authenticated user with control of a virtual registry upstream to make requests to internal hosts due to improper validation.

Weakness: CWE-918

Which versions are affected by CVE-2026-7471?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 18.8.018.9.7, 18.10.6, 18.11.3

Products include Gitlab Gitlab.

How do I fix CVE-2026-7471?

Upgrade gitlab to a fixed version for your release line: 18.9.7, 18.10.6 or 18.11.3.

Upgrade, and send outbound requests through an allow-list that blocks internal addresses. More about Server-side request forgery.

Is CVE-2026-7471 being exploited?

There is no known exploitation of CVE-2026-7471 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2026-7471, GHSA-v3gx-42r7-j2h7, UBUNTU-CVE-2026-7471.

Is CVE-2026-7471 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free