# CVE-2026-74761: Apache ActiveMQ Broker, Apache ActiveMQ All, Apache ActiveMQ: Spoofing of RemoveSubscription clientId

> An authenticated attacker can spoof client IDs to remove durable topic subscriptions, potentially disrupting message delivery or causing data loss.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Sep 2026
- **Updated:** 10 Sep 2026
- **Also known as:** BIT-activemq-2026-74761, GHSA-hx9m-72qj-2q46, MINI-7c26-hxmx-4r6h, MINI-8grj-mfmq-fq8x, MINI-jrxp-79f8-9vmj, MINI-mpw6-rvj8-h8rh, MINI-pf9c-fx6w-5rw3, MINI-v696-636v-53h5, OESA-2026-4046, OESA-2026-4047, OESA-2026-4048, OESA-2026-4049, UBUNTU-CVE-2026-74761

## What is CVE-2026-74761?

CVE-2026-74761 is a high-severity missing authorization vulnerability in Apache Activemq, published on 9 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Improper input validation in TopicRegion in Apache ActiveMQ, Apache ActiveMQ Broker, and Apache ActiveMQ All on all platforms.

An authenticated client can spoof clientId when removing a durable topic subscription.

This issue affects Apache ActiveMQ Broker: before 5.19.11, from 6.0.0 before 6.3.2; Apache ActiveMQ All: before 5.19.11, from 6.0.0 before 6.3.2; Apache ActiveMQ: before 5.19.11, from 6.0.0 before 6.3.2.

Users are recommended to upgrade to version 6.3.2 or 5.19.11 which fixes the issue.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2026-74761?

1 open source package ship an affected version, including activemq. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `activemq` | Bitnami | All versions | 5.19.11, 6.3.2 |

Products: Apache Activemq, Apache Activemq All, Apache Activemq Broker.

## How do I fix CVE-2026-74761?

Upgrade activemq to a fixed version for your release line: 5.19.11 or 6.3.2.

## Is CVE-2026-74761 being exploited?

There is no known exploitation of CVE-2026-74761 in the wild and no public exploit code.

## Other vulnerabilities in Apache Activemq

- [CVE-2023-46604](https://insights.sbomify.com/CVE-2023-46604/): Apache ActiveMQ Deserialization of Untrusted Data (critical 10.0, exploited in the wild)
- [CVE-2016-3088](https://insights.sbomify.com/CVE-2016-3088/): Apache ActiveMQ Improper Input Validation (critical 9.8, exploited in the wild)
- [CVE-2026-34197](https://insights.sbomify.com/CVE-2026-34197/): Apache ActiveMQ Improper Input Validation (high 8.8, exploited in the wild)
- [CVE-2020-11998](https://insights.sbomify.com/CVE-2020-11998/): Remote code execution in Apache ActiveMQ (critical 9.8)
- [CVE-2013-7285](https://insights.sbomify.com/CVE-2013-7285/): Command Injection in Xstream (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-74761 and fix it if it is affected.

What it is: CVE-2026-74761 is a high-severity missing authorization vulnerability in Apache Activemq, published on 9 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-74761 in the wild and no public exploit code.

Affected packages and fixed versions:
- activemq (Bitnami): affected all versions; fixed in 5.19.11, 6.3.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-74761/ (Markdown: https://insights.sbomify.com/CVE-2026-74761/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-74761
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-74761
- OSV: https://osv.dev/vulnerability/CVE-2026-74761

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-74761/
Summaries are generated and may contain mistakes; the official description above is the record.
