# CVE-2026-74783: Scriban 6.6.0 through 7.2.0 Parser Recursion Denial of Service

> Attackers can crash the host process by supplying templates with deeply nested expressions, bypassing the depth limit guard.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 16 Aug 2026
- **Updated:** 30 Sep 2026
- **Also known as:** GHSA-6q7j-xr26-3h2c, GHSA-jg4x-p32p-q6xr

## What is CVE-2026-74783?

CVE-2026-74783 is a high-severity denial of service vulnerability in scriban, published on 16 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Scriban versions 6.6.0 through 7.2.0 contain a non-enforcing ExpressionDepthLimit guard that fails to stop recursive descent parsing of deeply nested expressions. Attackers can supply templates with deeply nested parentheses, array initializers, object initializers, or unary operators to trigger an uncatchable StackOverflowException that immediately terminates the host process.

Weakness: CWE-674 (Uncontrolled Recursion)

## Which versions are affected by CVE-2026-74783?

4 open source packages ship an affected version, including Scriban and Scriban.Signed.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `Scriban` | NuGet | From 6.6.0 | 7.2.1 |
| `Scriban` | NuGet | From 6.6.0 | 7.2.1 |
| `Scriban.Signed` | NuGet | From 6.6.0 | 7.2.1 |
| `Scriban.Signed` | NuGet | From 6.6.0 | 7.2.1 |

## How do I fix CVE-2026-74783?

Upgrade Scriban to 7.2.1 or later.

## Is CVE-2026-74783 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-74783 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-74783 and fix it if it is affected.

What it is: CVE-2026-74783 is a high-severity denial of service vulnerability in scriban, published on 16 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-74783 exists.

Affected packages and fixed versions:
- Scriban (NuGet): affected from 6.6.0; fixed in 7.2.1
- Scriban (NuGet): affected from 6.6.0; fixed in 7.2.1
- Scriban.Signed (NuGet): affected from 6.6.0; fixed in 7.2.1
- Scriban.Signed (NuGet): affected from 6.6.0; fixed in 7.2.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-74783/ (Markdown: https://insights.sbomify.com/CVE-2026-74783/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-74783
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-74783
- OSV: https://osv.dev/vulnerability/CVE-2026-74783

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-74783/
Summaries are generated and may contain mistakes; the official description above is the record.
