# CVE-2026-74785: Scriban before 7.0.0 Denial of Service via Unbounded Resource Consumption

> Attackers supplying templates can cause out-of-memory or CPU exhaustion in Scriban, terminating the host process.

- **Severity:** High 7.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 16 Aug 2026
- **Updated:** 17 Aug 2026
- **Also known as:** GHSA-q5qx-vc88-69hw, GHSA-xw6w-9jjh-p9cr

## What is CVE-2026-74785?

CVE-2026-74785 is a high-severity denial of service vulnerability in scriban, published on 16 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Scriban before 7.0.0 contains three distinct denial-of-service vulnerabilities in expression evaluation that bypass existing safety controls through unbounded string multiplication, uncontrolled BigInteger shift operations, and LoopLimit bypass via range enumeration in builtin functions. Attackers who can supply templates can cause out-of-memory exceptions or CPU exhaustion, typically terminating the entire host process.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2026-74785?

4 open source packages ship an affected version, including Scriban and Scriban.Signed.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `Scriban` | NuGet | All versions | 7.0.0 |
| `Scriban` | NuGet | All versions | 7.0.0 |
| `Scriban.Signed` | NuGet | All versions | 7.0.0 |
| `Scriban.Signed` | NuGet | All versions | 7.0.0 |

## How do I fix CVE-2026-74785?

Upgrade Scriban to 7.0.0 or later.

## Is CVE-2026-74785 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-74785 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-74785 and fix it if it is affected.

What it is: CVE-2026-74785 is a high-severity denial of service vulnerability in scriban, published on 16 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-74785 exists.

Affected packages and fixed versions:
- Scriban (NuGet): affected all versions; fixed in 7.0.0
- Scriban (NuGet): affected all versions; fixed in 7.0.0
- Scriban.Signed (NuGet): affected all versions; fixed in 7.0.0
- Scriban.Signed (NuGet): affected all versions; fixed in 7.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-74785/ (Markdown: https://insights.sbomify.com/CVE-2026-74785/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-74785
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-74785
- OSV: https://osv.dev/vulnerability/CVE-2026-74785

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-74785/
Summaries are generated and may contain mistakes; the official description above is the record.
