{"answers":{"affected":"4 open source packages ship an affected version, including Scriban.Signed and scriban.","exploited":"There is no known exploitation of CVE-2026-74789 in the wild and no public exploit code.","fix":"Upgrade Scriban.Signed to 7.0.0 or later.","what":"CVE-2026-74789 is a high-severity denial of service vulnerability in scriban, published on 16 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-74789 and fix it if it is affected.\n\nWhat it is: CVE-2026-74789 is a high-severity denial of service vulnerability in scriban, published on 16 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-74789 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- Scriban.Signed (NuGet): affected all versions; fixed in 7.0.0\n- Scriban.Signed (NuGet): affected all versions; fixed in 7.0.0\n- scriban (NuGet): affected all versions; fixed in 7.0.0\n- scriban (NuGet): affected all versions; fixed in 7.0.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-74789/ (Markdown: https://insights.sbomify.com/CVE-2026-74789/index.md)","id":"CVE-2026-74789","markdown":"https://insights.sbomify.com/CVE-2026-74789/index.md","name":"CVE-2026-74789","record":{"aliases":["GHSA-5vwr-vwx4-9hc3","GHSA-c875-h985-hvrc"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Scriban templating library","requires_auth":"none","summary":"Attackers can cause denial of service in applications using Scriban by bypassing LoopLimit via expensive built-in operations.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulnCheck","cpe":[],"cvss":{"score":8.7,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-400","name":"Uncontrolled Resource Consumption"}],"description":"Scriban before 7.0.0 (affected \u003c= 6.6.0) applies its LoopLimit constraint only to script loop statements and not to expensive iteration performed inside built-in operators and functions. As a result, a single expression such as {{ 1..1000000 | array.size }} — or a memory-amplification expression such as {{ 'A' * 200000000 }} — can force large CPU or memory consumption even when LoopLimit is configured to a very small value, resulting in denial of service. Applications that render attacker-controlled templates and rely on LoopLimit for safe execution are affected.","ecosystems":["NuGet"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"Scriban before 7.0.0 LoopLimit Bypass via Built-in Operations","id":"CVE-2026-74789","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"NuGet","product":null,"products":[],"type":"denial_of_service","year":"2026"},"n_packages":4,"n_references":2,"next":{"headline":"Scriban before 7.0.0 MemberFilter Bypass via TemplateContext Cache","id":"CVE-2026-74790"},"packages":[{"ecosystem":"NuGet","fixed":["7.0.0"],"introduced":["0"],"last_affected":[],"package":"Scriban.Signed","purl":null,"source":"GHSA-c875-h985-hvrc"},{"ecosystem":"NuGet","fixed":["7.0.0"],"introduced":["0"],"last_affected":[],"package":"Scriban.Signed","purl":"pkg:nuget/Scriban.Signed","source":"GHSA-c875-h985-hvrc"},{"ecosystem":"NuGet","fixed":["7.0.0"],"introduced":["0"],"last_affected":[],"package":"scriban","purl":null,"source":"GHSA-c875-h985-hvrc"},{"ecosystem":"NuGet","fixed":["7.0.0"],"introduced":["0"],"last_affected":[],"package":"scriban","purl":"pkg:nuget/scriban","source":"GHSA-c875-h985-hvrc"}],"prev":{"headline":"Scriban before 7.0.0 Denial of Service via string.pad_left/pad_right","id":"CVE-2026-74788"},"products":["scriban"],"published":"2026-08-16","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-08-17","vendors":["scriban"]},"summary":"Attackers can cause denial of service in applications using Scriban by bypassing LoopLimit via expensive built-in operations.","url":"https://insights.sbomify.com/CVE-2026-74789/"}