# CVE-2026-74789: Scriban before 7.0.0 LoopLimit Bypass via Built-in Operations

> Attackers can cause denial of service in applications using Scriban by bypassing LoopLimit via expensive built-in operations.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 16 Aug 2026
- **Updated:** 17 Aug 2026
- **Also known as:** GHSA-5vwr-vwx4-9hc3, GHSA-c875-h985-hvrc

## What is CVE-2026-74789?

CVE-2026-74789 is a high-severity denial of service vulnerability in scriban, published on 16 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Scriban before 7.0.0 (affected <= 6.6.0) applies its LoopLimit constraint only to script loop statements and not to expensive iteration performed inside built-in operators and functions. As a result, a single expression such as {{ 1..1000000 | array.size }} — or a memory-amplification expression such as {{ 'A' * 200000000 }} — can force large CPU or memory consumption even when LoopLimit is configured to a very small value, resulting in denial of service. Applications that render attacker-controlled templates and rely on LoopLimit for safe execution are affected.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2026-74789?

4 open source packages ship an affected version, including Scriban.Signed and scriban.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `Scriban.Signed` | NuGet | All versions | 7.0.0 |
| `Scriban.Signed` | NuGet | All versions | 7.0.0 |
| `scriban` | NuGet | All versions | 7.0.0 |
| `scriban` | NuGet | All versions | 7.0.0 |

## How do I fix CVE-2026-74789?

Upgrade Scriban.Signed to 7.0.0 or later.

## Is CVE-2026-74789 being exploited?

There is no known exploitation of CVE-2026-74789 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-74789 and fix it if it is affected.

What it is: CVE-2026-74789 is a high-severity denial of service vulnerability in scriban, published on 16 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-74789 in the wild and no public exploit code.

Affected packages and fixed versions:
- Scriban.Signed (NuGet): affected all versions; fixed in 7.0.0
- Scriban.Signed (NuGet): affected all versions; fixed in 7.0.0
- scriban (NuGet): affected all versions; fixed in 7.0.0
- scriban (NuGet): affected all versions; fixed in 7.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-74789/ (Markdown: https://insights.sbomify.com/CVE-2026-74789/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-74789
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-74789
- OSV: https://osv.dev/vulnerability/CVE-2026-74789

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-74789/
Summaries are generated and may contain mistakes; the official description above is the record.
