CVE-2026-74792 Scriban before 7.0.0 Stack Overflow via nested array initializers

High 8.7 Published Updated

Attackers can crash applications using Scriban by supplying deeply nested array initializers, causing an uncatchable stack overflow.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2026-74792?

CVE-2026-74792 is a high-severity denial of service vulnerability in scriban, published on 16 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Scriban before 7.0.0 (affected versions <= 6.6.0) contains a stack overflow vulnerability in nested array initializer parsing. Deeply nested array initializers recurse through a path (ParseArrayInitializer → ParseExpression → ParseArrayInitializer) that is not covered by the ExpressionDepthLimit counter added in the fix for GHSA-wgh7-7m3c-fx25. An attacker who can supply untrusted input to Template.Parse can trigger an uncatchable StackOverflowException that immediately terminates the process, even with the default ExpressionDepthLimit enabled.

Weakness: CWE-674

Which versions are affected by CVE-2026-74792?

4 open source packages ship an affected version, including Scriban and Scriban.Signed.

PackageAffectedFixed in
Scriban NuGetAll versions7.0.0
Scriban NuGetAll versions7.0.0
Scriban.Signed NuGetAll versions7.0.0
Scriban.Signed NuGetAll versions7.0.0

How do I fix CVE-2026-74792?

Upgrade Scriban to 7.0.0 or later.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2026-74792 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-74792 exists.

Sources

Also known as GHSA-6g73-98rg-crm7, GHSA-p6q4-fgr8-vx4p.

Is CVE-2026-74792 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free