{"answers":{"affected":"4 open source packages ship an affected version, including Scriban and Scriban.Signed.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-74792 exists.","fix":"Upgrade Scriban to 7.0.0 or later.","what":"CVE-2026-74792 is a high-severity denial of service vulnerability in scriban, published on 16 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-74792 and fix it if it is affected.\n\nWhat it is: CVE-2026-74792 is a high-severity denial of service vulnerability in scriban, published on 16 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-74792 exists.\n\nAffected packages and fixed versions:\n- Scriban (NuGet): affected all versions; fixed in 7.0.0\n- Scriban (NuGet): affected all versions; fixed in 7.0.0\n- Scriban.Signed (NuGet): affected all versions; fixed in 7.0.0\n- Scriban.Signed (NuGet): affected all versions; fixed in 7.0.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-74792/ (Markdown: https://insights.sbomify.com/CVE-2026-74792/index.md)","id":"CVE-2026-74792","markdown":"https://insights.sbomify.com/CVE-2026-74792/index.md","name":"CVE-2026-74792","record":{"aliases":["GHSA-6g73-98rg-crm7","GHSA-p6q4-fgr8-vx4p"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Scriban template library","requires_auth":"none","summary":"Attackers can crash applications using Scriban by supplying deeply nested array initializers, causing an uncatchable stack overflow.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulnCheck","cpe":[],"cvss":{"score":8.7,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-674","name":"Uncontrolled Recursion"}],"description":"Scriban before 7.0.0 (affected versions \u003c= 6.6.0) contains a stack overflow vulnerability in nested array initializer parsing. Deeply nested array initializers recurse through a path (ParseArrayInitializer → ParseExpression → ParseArrayInitializer) that is not covered by the ExpressionDepthLimit counter added in the fix for GHSA-wgh7-7m3c-fx25. An attacker who can supply untrusted input to Template.Parse can trigger an uncatchable StackOverflowException that immediately terminates the process, even with the default ExpressionDepthLimit enabled.","ecosystems":["NuGet"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":false,"headline":"Scriban before 7.0.0 Stack Overflow via nested array initializers","id":"CVE-2026-74792","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"NuGet","product":null,"products":[],"type":"denial_of_service","year":"2026"},"n_packages":4,"n_references":2,"next":{"headline":"justhtml before 3.11.0 XSS via selectedcontent projection","id":"CVE-2026-74793"},"packages":[{"ecosystem":"NuGet","fixed":["7.0.0"],"introduced":["0"],"last_affected":[],"package":"Scriban","purl":null,"source":"GHSA-p6q4-fgr8-vx4p"},{"ecosystem":"NuGet","fixed":["7.0.0"],"introduced":["0"],"last_affected":[],"package":"Scriban","purl":"pkg:nuget/Scriban","source":"GHSA-p6q4-fgr8-vx4p"},{"ecosystem":"NuGet","fixed":["7.0.0"],"introduced":["0"],"last_affected":[],"package":"Scriban.Signed","purl":null,"source":"GHSA-p6q4-fgr8-vx4p"},{"ecosystem":"NuGet","fixed":["7.0.0"],"introduced":["0"],"last_affected":[],"package":"Scriban.Signed","purl":"pkg:nuget/Scriban.Signed","source":"GHSA-p6q4-fgr8-vx4p"}],"prev":{"headline":"Scriban before 7.0.0 Authorization Bypass via Stale Include Cache","id":"CVE-2026-74791"},"products":["scriban"],"published":"2026-08-16","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-08-18","vendors":["scriban"]},"summary":"Attackers can crash applications using Scriban by supplying deeply nested array initializers, causing an uncatchable stack overflow.","url":"https://insights.sbomify.com/CVE-2026-74792/"}