# CVE-2026-74792: Scriban before 7.0.0 Stack Overflow via nested array initializers

> Attackers can crash applications using Scriban by supplying deeply nested array initializers, causing an uncatchable stack overflow.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 16 Aug 2026
- **Updated:** 18 Aug 2026
- **Also known as:** GHSA-6g73-98rg-crm7, GHSA-p6q4-fgr8-vx4p

## What is CVE-2026-74792?

CVE-2026-74792 is a high-severity denial of service vulnerability in scriban, published on 16 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Scriban before 7.0.0 (affected versions <= 6.6.0) contains a stack overflow vulnerability in nested array initializer parsing. Deeply nested array initializers recurse through a path (ParseArrayInitializer → ParseExpression → ParseArrayInitializer) that is not covered by the ExpressionDepthLimit counter added in the fix for GHSA-wgh7-7m3c-fx25. An attacker who can supply untrusted input to Template.Parse can trigger an uncatchable StackOverflowException that immediately terminates the process, even with the default ExpressionDepthLimit enabled.

Weakness: CWE-674 (Uncontrolled Recursion)

## Which versions are affected by CVE-2026-74792?

4 open source packages ship an affected version, including Scriban and Scriban.Signed.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `Scriban` | NuGet | All versions | 7.0.0 |
| `Scriban` | NuGet | All versions | 7.0.0 |
| `Scriban.Signed` | NuGet | All versions | 7.0.0 |
| `Scriban.Signed` | NuGet | All versions | 7.0.0 |

## How do I fix CVE-2026-74792?

Upgrade Scriban to 7.0.0 or later.

## Is CVE-2026-74792 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-74792 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-74792 and fix it if it is affected.

What it is: CVE-2026-74792 is a high-severity denial of service vulnerability in scriban, published on 16 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-74792 exists.

Affected packages and fixed versions:
- Scriban (NuGet): affected all versions; fixed in 7.0.0
- Scriban (NuGet): affected all versions; fixed in 7.0.0
- Scriban.Signed (NuGet): affected all versions; fixed in 7.0.0
- Scriban.Signed (NuGet): affected all versions; fixed in 7.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-74792/ (Markdown: https://insights.sbomify.com/CVE-2026-74792/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-74792
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-74792
- OSV: https://osv.dev/vulnerability/CVE-2026-74792

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-74792/
Summaries are generated and may contain mistakes; the official description above is the record.
