# CVE-2026-7482: Ollama heap out-of-bounds read in GGUF tensor parsing leaks server process memory to unauthenticated remote attackers

> Unauthenticated attackers can leak server memory via malformed GGUF files, exposing secrets and user data if the server is exposed to the network.

- **Severity:** High 8.8 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:H/SC:N/SI:N/SA:N/AU:Y/R:A/V:D/RE:L/U:Red`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 May 2026
- **Updated:** 4 May 2026
- **Also known as:** GHSA-x8qc-fggm-mpqg, GO-2026-5748, MINI-478v-jgqg-cx74, openSUSE-SU-2026:11688-1

## What is CVE-2026-7482?

CVE-2026-7482 is a high-severity vulnerability in ollama, published on 4 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Ollama before 0.17.1 contains a heap out-of-bounds read vulnerability in the GGUF model loader. The /api/create endpoint accepts an attacker-supplied GGUF file in which the declared tensor offset and size exceed the file's actual length; during quantization in fs/ggml/gguf.go and server/quantization.go (WriteTo()), the server reads past the allocated heap buffer. The leaked memory contents may include environment variables, API keys, system prompts, and concurrent users' conversation data, and can be exfiltrated by uploading the resulting model artifact through the /api/push endpoint to an attacker-controlled registry. The /api/create and /api/push endpoints have no authentication in the upstream distribution. Default deployments bind to 127.0.0.1, but the documented OLLAMA_HOST=0.0.0.0 configuration is widely used in practice (large public-internet exposure observed).

Weakness: CWE-125 (Out-of-bounds Read)

## Which versions are affected by CVE-2026-7482?

3 open source packages ship an affected version, including github.com/ollama/ollama. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/ollama/ollama` | Go | All versions | 0.17.1 |
| `github.com/ollama/ollama` | Go | All versions | 0.17.1 |
| `github.com/ollama/ollama` | Go | All versions | 0.17.1 |
| `ollama` | openSUSE:Tumbleweed | All versions | 0.33.1-1.1 |

Products: Ollama Ollama.

## How do I fix CVE-2026-7482?

Upgrade github.com/ollama/ollama to 0.17.1 or later.

## Is CVE-2026-7482 being exploited?

There is no known exploitation of CVE-2026-7482 in the wild and no public exploit code.

Public exploit code:

- 1day vuln research I guess (github_poc): https://github.com/0x0OZ/CVE-2026-7482-PoC
- Ollama CVE-2026-7482 Heap OOB read reproduction and black-box impact notes (github_poc): https://github.com/szybnev/CVE-2026-7482
- https://github.com/kaleth4/CVE-2026-7482 (github_poc): https://github.com/kaleth4/CVE-2026-7482

## Other vulnerabilities in ollama

- [CVE-2025-63389](https://insights.sbomify.com/CVE-2025-63389/): Ollama Platform has missing authentication enabling attackers to perform model management operations (critical 9.8)
- [CVE-2024-45436](https://insights.sbomify.com/CVE-2024-45436/): Ollama can extract members of a ZIP archive outside of the parent directory (critical 9.1)
- [CVE-2024-37032](https://insights.sbomify.com/CVE-2024-37032/): Ollama does not validate the format of the digest (sha256 with 64 hex digits) (high 8.8)
- [CVE-2025-15514](https://insights.sbomify.com/CVE-2025-15514/): Ollama Multi-Modal Model Image Processing NULL Pointer Dereference (high 8.7)
- [CVE-2024-39720](https://insights.sbomify.com/CVE-2024-39720/): Ollama Out-of-bounds Read (high 8.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-7482 and fix it if it is affected.

What it is: CVE-2026-7482 is a high-severity vulnerability in ollama, published on 4 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-7482 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/ollama/ollama (Go): affected all versions; fixed in 0.17.1
- github.com/ollama/ollama (Go): affected all versions; fixed in 0.17.1
- github.com/ollama/ollama (Go): affected all versions; fixed in 0.17.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-7482/ (Markdown: https://insights.sbomify.com/CVE-2026-7482/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-7482
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-7482
- OSV: https://osv.dev/vulnerability/CVE-2026-7482

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-7482/
Summaries are generated and may contain mistakes; the official description above is the record.
