CVE-2026-74848 Apache APISIX: Cross-user response poisoning in serverless plugins
Attackers can poison responses for other clients on serverless plugin routes, leading to data exposure or modification in Apache APISIX.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-74848?
CVE-2026-74848 is a high-severity vulnerability in Apache APISIX, published on 27 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Inconsistent Interpretation of HTTP Requests ('HTTP Request/Response Smuggling') vulnerability in Apache APISIX.
An attacker could make other clients receive attacker-chosen or other users' responses on serverless-plugin routes.
This issue affects Apache APISIX: from 2.12.0 through 3.17.0.
Users are recommended to upgrade to version 3.18.0, which fixes the issue.
Weakness: CWE-444
Which versions are affected by CVE-2026-74848?
1 open source package ship an affected version, including apisix. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
apisix Bitnami | From 2.12.0 | 3.18.0 |
Products include Apache Apisix.
How do I fix CVE-2026-74848?
Upgrade apisix to 3.18.0 or later.
Is CVE-2026-74848 being exploited?
There is no known exploitation of CVE-2026-74848 in the wild and no public exploit code.
Other vulnerabilities in Apache APISIX
- CVE-2022-24112 Apache APISIX Authentication Bypass
- CVE-2022-25757 Apache APISIX: the body_schema check in request-validation plugin can be bypassed
- CVE-2026-31908 Apache APISIX: forward auth plugin allows header injection
- CVE-2026-75005 Apache APISIX: Unauthenticated CPU-exhaustion DoS
- CVE-2025-27446 Privilege escalation in Apache APISIX Java Plugin Runner
Sources
Also known as BIT-apisix-2026-74848, GHSA-3g86-xcpq-wppj, MINI-rf49-7gxh-8wg4.