{"answers":{"affected":"1 open source package ship an affected version, including apisix. It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-74848 in the wild and no public exploit code.","fix":"Upgrade apisix to 3.18.0 or later.","what":"CVE-2026-74848 is a high-severity vulnerability in Apache APISIX, published on 27 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-74848 and fix it if it is affected.\n\nWhat it is: CVE-2026-74848 is a high-severity vulnerability in Apache APISIX, published on 27 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-74848 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- apisix (Bitnami): affected from 2.12.0; fixed in 3.18.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-74848/ (Markdown: https://insights.sbomify.com/CVE-2026-74848/index.md)","id":"CVE-2026-74848","markdown":"https://insights.sbomify.com/CVE-2026-74848/index.md","name":"CVE-2026-74848","record":{"aliases":["BIT-apisix-2026-74848","GHSA-3g86-xcpq-wppj","MINI-rf49-7gxh-8wg4"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["data_read","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"API Gateway","requires_auth":"none","summary":"Attackers can poison responses for other clients on serverless plugin routes, leading to data exposure or modification in Apache APISIX.","user_interaction":"not_required","vuln_class":"other"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"apisix","vendor":"apache"}],"cvss":{"score":7,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:N/SC:H/SI:H/SA:N","version":"4.0"},"cwes":[{"id":"CWE-444","name":"Inconsistent Interpretation of HTTP Requests"}],"description":"Inconsistent Interpretation of HTTP Requests ('HTTP Request/Response Smuggling') vulnerability in Apache APISIX.\n\nAn attacker could make other clients receive attacker-chosen or other users' responses on serverless-plugin routes.\n\nThis issue affects Apache APISIX: from 2.12.0 through 3.17.0.\n\nUsers are recommended to upgrade to version 3.18.0, which fixes the issue.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Apache APISIX: Cross-user response poisoning in serverless plugins","id":"CVE-2026-74848","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"other","year":"2026"},"n_packages":1,"n_references":1,"next":{"headline":"Remote code execution vulnerability","id":"CVE-2026-74849"},"packages":[{"ecosystem":"Bitnami","fixed":["3.18.0"],"introduced":["2.12.0"],"last_affected":[],"package":"apisix","purl":"pkg:bitnami/apisix","source":"BIT-apisix-2026-74848"}],"prev":{"headline":"2100 Technology｜Official Document Management System - Arbitrary File Upload","id":"CVE-2026-74845"},"products":["Apache APISIX"],"published":"2026-08-27","related":[{"cvss_score":9.8,"headline":"Apache APISIX Authentication Bypass","id":"CVE-2022-24112","kev_date_added":"2022-08-25","published":"2022-02-11"},{"cvss_score":9.8,"headline":"Apache APISIX: the body_schema check in request-validation plugin can be bypassed","id":"CVE-2022-25757","kev_date_added":null,"published":"2022-03-28"},{"cvss_score":9.1,"headline":"Apache APISIX: forward auth plugin allows header injection","id":"CVE-2026-31908","kev_date_added":null,"published":"2026-04-14"},{"cvss_score":8.7,"headline":"Apache APISIX: Unauthenticated CPU-exhaustion DoS","id":"CVE-2026-75005","kev_date_added":null,"published":"2026-08-27"},{"cvss_score":7.8,"headline":"Privilege escalation in Apache APISIX Java Plugin Runner","id":"CVE-2025-27446","kev_date_added":null,"published":"2025-07-06"},{"cvss_score":7.5,"headline":"Apache APISIX: Openid-connect `tls_verify` field is disabled by default","id":"CVE-2026-31923","kev_date_added":null,"published":"2026-04-14"},{"cvss_score":7.5,"headline":"Apache APISIX: basic-auth logs plaintext credentials at info level","id":"CVE-2025-62232","kev_date_added":null,"published":"2025-10-31"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-08-27","vendors":["Apache Software Foundation"]},"summary":"Attackers can poison responses for other clients on serverless plugin routes, leading to data exposure or modification in Apache APISIX.","url":"https://insights.sbomify.com/CVE-2026-74848/"}