# CVE-2026-74907: Grav before 2.0.15 Path Traversal via plugin-asset-map.php

> Unauthenticated attackers can read files from sibling directories in Grav CMS due to improper path validation in the static asset server.

- **Severity:** High 8.2 (`CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Aug 2026
- **Updated:** 8 Oct 2026
- **Also known as:** GHSA-4v9q-p283-qc2m

## What is CVE-2026-74907?

CVE-2026-74907 is a high-severity path traversal vulnerability in getgrav grav, published on 18 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Grav before 2.0.15 contains a path traversal vulnerability in the static asset server within index.php that uses string prefix matching instead of directory-boundary validation. Unauthenticated attackers can access files in sibling directories by exploiting directory names that extend the base path string, such as requesting assets-secret when assets is the configured base.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-74907?

2 open source packages ship an affected version, including getgrav/grav.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `getgrav/grav` | Packagist | All versions | 2.0.15 |
| `getgrav/grav` | Packagist | All versions | 2.0.15 |

## How do I fix CVE-2026-74907?

Upgrade getgrav/grav to 2.0.15 or later.

## Is CVE-2026-74907 being exploited?

There is no known exploitation of CVE-2026-74907 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-74907 and fix it if it is affected.

What it is: CVE-2026-74907 is a high-severity path traversal vulnerability in getgrav grav, published on 18 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-74907 in the wild and no public exploit code.

Affected packages and fixed versions:
- getgrav/grav (Packagist): affected all versions; fixed in 2.0.15
- getgrav/grav (Packagist): affected all versions; fixed in 2.0.15

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-74907/ (Markdown: https://insights.sbomify.com/CVE-2026-74907/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-74907
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-74907
- OSV: https://osv.dev/vulnerability/CVE-2026-74907

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-74907/
Summaries are generated and may contain mistakes; the official description above is the record.
