CVE-2026-75005 Apache APISIX: Unauthenticated CPU-exhaustion DoS

High 8.7 Published Updated

An unauthenticated attacker can cause CPU exhaustion and denial of service in Apache APISIX via graphql-limit-count routes.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-75005?

CVE-2026-75005 is a high-severity denial of service vulnerability in Apache APISIX, published on 27 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Inefficient Algorithmic Complexity vulnerability in Apache APISIX.

A single small request can pin a gateway worker at 100% CPU for an extended period in graphql-limit-count routes.

This issue affects Apache APISIX: 3.17.0.

Users are recommended to upgrade to version 3.18.0, which fixes the issue.

Weakness: CWE-407

Which versions are affected by CVE-2026-75005?

1 open source package ship an affected version, including apisix. It affects 1 product.

PackageAffectedFixed in
apisix BitnamiFrom 3.17.03.18.0

Products include Apache Apisix.

How do I fix CVE-2026-75005?

Upgrade apisix to 3.18.0 or later.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2026-75005 being exploited?

There is no known exploitation of CVE-2026-75005 in the wild and no public exploit code.

Sources

Also known as BIT-apisix-2026-75005, GHSA-7p87-32cx-94g2, MINI-hqgj-62jr-7pmh.

Is CVE-2026-75005 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free