CVE-2026-75015 Apache Syncope: Nested secrets leak cleartext into audit records readable

Medium 4.9 Published Updated

Attackers with admin access can view cleartext secrets in audit logs due to insufficient masking, exposing sensitive credentials.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2026-75015?

CVE-2026-75015 is a medium-severity vulnerability in Apache Syncope, published on 14 Sep 2026. An attacker needs administrator access to exploit it, with no action from the victim.

Official description

Insufficiently Protected Credentials vulnerability in Apache Syncope.

Audit events, when sent to the configured store, are not sufficiently masked for the sensitive values they might carry on their payloads, thus allowing administrators to access such sensitive values.

This issue affects Apache Syncope: from 3.0.0-M0 through 3.0.16, from 4.0.0-M0 Through 4.0.7, from 4.1.0-M0 through 4.1.2.

Users are recommended to upgrade to version 4.0.8 / 4.1.3, which fix this issue.

Weakness: CWE-522

Which versions are affected by CVE-2026-75015?

How do I fix CVE-2026-75015?

No fix has been published for CVE-2026-75015 yet. Limit exposure of the affected software until one is available.

Is CVE-2026-75015 being exploited?

There is no known exploitation of CVE-2026-75015 in the wild and no public exploit code.

Sources

Also known as GHSA-p5vm-7q6r-6j5w.

Is CVE-2026-75015 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free