CVE-2026-75020 Apache APISIX: ldap-auth plugin cross-subtree identity impersonation

High 7.0 Published Updated

Attackers with valid credentials can impersonate other users via LDAP injection in Apache APISIX, bypassing access controls.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-75020?

CVE-2026-75020 is a high-severity vulnerability in Apache APISIX, published on 27 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Improper Neutralization of Special Elements used in an LDAP Query ('LDAP Injection') vulnerability in Apache APISIX.

A caller who holds valid credentials for one entry in the LDAP directory can authenticate through APISIX as a consumer mapped to a different entry, one the plugin's configured scope was meant to keep out of reach.

This issue affects Apache APISIX: from 2.11.0 through 3.17.0.

Users are recommended to upgrade to version 3.18.0, which fixes the issue.

Weakness: CWE-90

Which versions are affected by CVE-2026-75020?

1 open source package ship an affected version, including apisix. It affects 1 product.

PackageAffectedFixed in
apisix BitnamiFrom 2.11.03.18.0

Products include Apache Apisix.

How do I fix CVE-2026-75020?

Upgrade apisix to 3.18.0 or later.

Is CVE-2026-75020 being exploited?

There is no known exploitation of CVE-2026-75020 in the wild and no public exploit code.

Sources

Also known as BIT-apisix-2026-75020, GHSA-fm68-53hc-8wxg, MINI-48f5-v7vh-jqh4.

Is CVE-2026-75020 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free