# CVE-2026-7507: Org.keycloak/keycloak-services: session fixation in oidc login flow that can lead to account takeover

> An attacker can hijack user sessions via a crafted link in Keycloak's login flow, leading to complete account takeover including admin privileges.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 19 May 2026
- **Updated:** 6 Oct 2026
- **Also known as:** BIT-keycloak-2026-7507, ECHO-bd3c-e7a2-8a3a, GHSA-hf67-5vvq-fm3r, MINI-29jr-5rgh-pvr3, MINI-55g3-r6c6-8qwp

## What is CVE-2026-7507?

CVE-2026-7507 is a high-severity authentication bypass vulnerability in Redhat Build of Keycloak, published on 19 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

A session fixation vulnerability was found in Keycloak's login-actions endpoints. An unauthenticated attacker could exploit this flaw by pre-creating an authentication session and tricking a victim into visiting a maliciously crafted link. By leveraging the /login-actions/restart endpoint—which processes session handles without adequate CSRF protection or cookie ownership validation—an attacker can reset the authentication flow state. This causes Single Sign-On (SSO) to authenticate the victim transparently upon clicking the link, allowing the attacker to hijack the required-action form without needing the victim's credentials. A successful exploit could lead to complete account takeover, including highly privileged administrative accounts.

Weakness: CWE-290 (Authentication Bypass by Spoofing)

## Which versions are affected by CVE-2026-7507?

3 open source packages ship an affected version, including org.keycloak:keycloak-services and keycloak. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.keycloak:keycloak-services` | Maven | All versions | 26.6.2 |
| `org.keycloak:keycloak-services` | Maven | All versions | 26.6.2 |
| `keycloak` | Bitnami | From 26.4.0 | 26.4.12 |

Products: Redhat Build of Keycloak.

## How do I fix CVE-2026-7507?

Upgrade org.keycloak:keycloak-services to 26.6.2 or later.

## Is CVE-2026-7507 being exploited?

There is no known exploitation of CVE-2026-7507 in the wild and no public exploit code.

## Other vulnerabilities in Redhat Build of Keycloak

- [CVE-2026-15572](https://insights.sbomify.com/CVE-2026-15572/): Keycloak-services: keycloak-services: dcr protocol mapper type-swap policy bypass allows privilege escalation (high 8.8)
- [CVE-2026-3047](https://insights.sbomify.com/CVE-2026-3047/): Keycloak SAML Broken has Authentication Bypass by Primary Weakness (high 8.8)
- [CVE-2026-15573](https://insights.sbomify.com/CVE-2026-15573/): Keycloak-services: keycloak-services: authorization bypass via unnormalized uri matching in pathmatcher (high 8.1)
- [CVE-2026-16102](https://insights.sbomify.com/CVE-2026-16102/): Keycloak-services: keycloak-services: default dcr policy allows role forgery via user property mappers (high 8.1)
- [CVE-2026-1609](https://insights.sbomify.com/CVE-2026-1609/): Org.keycloak/keycloak-quarkus-server: keycloak: unauthorized access via jwt authorization grant with disabled users (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-7507 and fix it if it is affected.

What it is: CVE-2026-7507 is a high-severity authentication bypass vulnerability in Redhat Build of Keycloak, published on 19 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-7507 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.keycloak:keycloak-services (Maven): affected all versions; fixed in 26.6.2
- org.keycloak:keycloak-services (Maven): affected all versions; fixed in 26.6.2
- keycloak (Bitnami): affected from 26.4.0; fixed in 26.4.12

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-7507/ (Markdown: https://insights.sbomify.com/CVE-2026-7507/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-7507
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-7507
- OSV: https://osv.dev/vulnerability/CVE-2026-7507

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-7507/
Summaries are generated and may contain mistakes; the official description above is the record.
