CVE-2026-75131 NetworkManager-l2tp Privilege Escalation via pppd Username Injection

High 8.5 Published Updated

Local users can escalate privileges to root by injecting pppd options via a crafted VPN username in NetworkManager-l2tp.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Local or same network only
Victim action needed
Not needed
Fix
Available

What is CVE-2026-75131?

CVE-2026-75131 is a high-severity vulnerability in nm-l2tp NetworkManager-l2tp, published on 23 Sep 2026. It can only be exploited from the same machine or local network, with no action from the victim.

Official description

NetworkManager-l2tp through 1.52.4, fixed in 1.52.6, contains a privilege escalation vulnerability that allows local users with permission to create VPN connections to execute arbitrary code as root by injecting pppd options through a crafted VPN username. Attackers can embed a double-quote character or whitespace in the username to break out of the pppd options file quoting context and include the pppd plugin directive, causing the privileged pppd process to load an attacker-controlled shared object.

Weakness: CWE-88

Which versions are affected by CVE-2026-75131?

How do I fix CVE-2026-75131?

Upgrade to a fixed version.

Is CVE-2026-75131 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-75131 exists.

Sources

Also known as DEBIAN-CVE-2026-75131, GHSA-v2wj-xr2m-xc4j, UBUNTU-CVE-2026-75131.

Is CVE-2026-75131 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free