# CVE-2026-75131: NetworkManager-l2tp Privilege Escalation via pppd Username Injection

> Local users can escalate privileges to root by injecting pppd options via a crafted VPN username in NetworkManager-l2tp.

- **Severity:** High 8.5 (`CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Sep 2026
- **Updated:** 23 Sep 2026
- **Also known as:** DEBIAN-CVE-2026-75131, GHSA-v2wj-xr2m-xc4j, UBUNTU-CVE-2026-75131

## What is CVE-2026-75131?

CVE-2026-75131 is a high-severity vulnerability in nm-l2tp NetworkManager-l2tp, published on 23 Sep 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

NetworkManager-l2tp through 1.52.4, fixed in 1.52.6, contains a privilege escalation vulnerability that allows local users with permission to create VPN connections to execute arbitrary code as root by injecting pppd options through a crafted VPN username. Attackers can embed a double-quote character or whitespace in the username to break out of the pppd options file quoting context and include the pppd plugin directive, causing the privileged pppd process to load an attacker-controlled shared object.

Weakness: CWE-88 (Improper Neutralization of Argument Delimiters in a Command)

## Which versions are affected by CVE-2026-75131?


## How do I fix CVE-2026-75131?

Upgrade to a fixed version.

## Is CVE-2026-75131 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-75131 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-75131 and fix it if it is affected.

What it is: CVE-2026-75131 is a high-severity vulnerability in nm-l2tp NetworkManager-l2tp, published on 23 Sep 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-75131 exists.

Affected product: nm-l2tp NetworkManager-l2tp. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-75131/ (Markdown: https://insights.sbomify.com/CVE-2026-75131/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-75131
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-75131
- OSV: https://osv.dev/vulnerability/CVE-2026-75131

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-75131/
Summaries are generated and may contain mistakes; the official description above is the record.
