CVE-2026-75140 jsoup Uncontrolled Resource Consumption in XmlTreeBuilder
Remote attackers can exhaust JVM heap memory and crash applications by sending deeply nested XML documents to the jsoup library.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-75140?
CVE-2026-75140 is a high-severity denial of service vulnerability in jhy soup, published on 20 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
jsoup through 1.23.2, fixed in commit 862ba2f, contains an uncontrolled resource consumption vulnerability in XmlTreeBuilder that allows remote attackers to exhaust JVM heap memory by supplying a deeply nested XML document with uniquely-namespaced elements. The builder copies the entire inherited namespace map on every start element, causing quadratic time and memory complexity, which attackers can exploit to trigger an OutOfMemoryError and terminate the application.
Weakness: CWE-770
Which versions are affected by CVE-2026-75140?
2 open source packages ship an affected version, including org.jsoup:jsoup.
| Package | Affected | Fixed in |
|---|---|---|
org.jsoup:jsoup Maven | All versions | 1.23.2 |
org.jsoup:jsoup Maven | All versions | 1.23.2 |
Linux distribution packages (18)
jsoup SUSE:Linux Enterprise High Performance Computing 15 SP4-ESPOS | All versions | 1.23.2-150200.3.14.1 |
jsoup SUSE:Linux Enterprise High Performance Computing 15 SP4-LTSS | All versions | 1.23.2-150200.3.14.1 |
jsoup SUSE:Linux Enterprise High Performance Computing 15 SP5-ESPOS | All versions | 1.23.2-150200.3.14.1 |
jsoup SUSE:Linux Enterprise High Performance Computing 15 SP5-LTSS | All versions | 1.23.2-150200.3.14.1 |
jsoup SUSE:Linux Enterprise Module for Development Tools 15 SP7 | All versions | 1.23.2-150200.3.14.1 |
jsoup SUSE:Linux Enterprise Server 15 SP4-LTSS | All versions | 1.23.2-150200.3.14.1 |
jsoup SUSE:Linux Enterprise Server 15 SP5-LTSS | All versions | 1.23.2-150200.3.14.1 |
jsoup SUSE:Linux Enterprise Server 15 SP6-LTSS | All versions | 1.23.2-150200.3.14.1 |
jsoup SUSE:Linux Enterprise Server 16.0 | All versions | 1.23.2-160000.1.1 |
jsoup SUSE:Linux Enterprise Server 16.0 | All versions | 1.23.2-160000.1.1 |
jsoup SUSE:Linux Enterprise Server for SAP Applications 15 SP4 | All versions | 1.23.2-150200.3.14.1 |
jsoup SUSE:Linux Enterprise Server for SAP Applications 15 SP5 | All versions | 1.23.2-150200.3.14.1 |
jsoup SUSE:Linux Enterprise Server for SAP Applications 15 SP6 | All versions | 1.23.2-150200.3.14.1 |
jsoup SUSE:Linux Enterprise Server for SAP applications 16.0 | All versions | 1.23.2-160000.1.1 |
jsoup SUSE:Linux Enterprise Server for SAP applications 16.0 | All versions | 1.23.2-160000.1.1 |
jsoup openSUSE:Leap 16.0 | All versions | 1.23.2-160000.1.1 |
re2j openSUSE:Leap 16.0 | All versions | 1.8-160000.1.1 |
jsoup openSUSE:Tumbleweed | All versions | 1.23.2-1.1 |
How do I fix CVE-2026-75140?
Upgrade org.jsoup:jsoup to 1.23.2 or later.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2026-75140 being exploited?
There is no known exploitation of CVE-2026-75140 in the wild and no public exploit code.
Sources
Also known as AZL-103529, CLEANSTART-2026-NX44968, CLEANSTART-2026-PI17373, CLEANSTART-2026-WT61032, CLEANSTART-2026-ZP93019, DEBIAN-CVE-2026-75140 and 25 more.