# CVE-2026-75140: jsoup Uncontrolled Resource Consumption in XmlTreeBuilder

> Remote attackers can exhaust JVM heap memory and crash applications by sending deeply nested XML documents to the jsoup library.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Aug 2026
- **Updated:** 21 Aug 2026
- **Also known as:** AZL-103529, CLEANSTART-2026-NX44968, CLEANSTART-2026-PI17373, CLEANSTART-2026-WT61032, CLEANSTART-2026-ZP93019, DEBIAN-CVE-2026-75140, ECHO-2a6b-66ba-55ca, GHSA-65r4-943x-97jj, MINI-2m8p-692m-46rq, MINI-2xrx-rphq-m8rw, MINI-4c9f-m464-mf3w, MINI-58j7-7jq7-79r8, MINI-5j9f-jwpg-6g58, MINI-768j-898q-cqf9, MINI-c37r-pvq8-rgv2, MINI-c8p3-qcwh-c595, MINI-cf24-666c-2qh4, MINI-cq9g-8hfh-wmv6, MINI-hcc8-q2w4-p532, MINI-hp82-8792-xq4q, MINI-mjcr-gwcx-9pr5, MINI-qqc8-7x5h-pwvv, MINI-vg42-rg58-wf7q, MINI-wh4j-cpf4-xppm, ROOT-APP-MAVEN-CVE-2026-75140, SUSE-SU-2026:23856-1, SUSE-SU-2026:23867-1, SUSE-SU-2026:4393-1, UBUNTU-CVE-2026-75140, openSUSE-SU-2026:11702-1, openSUSE-SU-2026:21900-1

## What is CVE-2026-75140?

CVE-2026-75140 is a high-severity denial of service vulnerability in jhy soup, published on 20 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

jsoup through 1.23.2, fixed in commit 862ba2f, contains an uncontrolled resource consumption vulnerability in XmlTreeBuilder that allows remote attackers to exhaust JVM heap memory by supplying a deeply nested XML document with uniquely-namespaced elements. The builder copies the entire inherited namespace map on every start element, causing quadratic time and memory complexity, which attackers can exploit to trigger an OutOfMemoryError and terminate the application.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2026-75140?

2 open source packages ship an affected version, including org.jsoup:jsoup.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jsoup:jsoup` | Maven | All versions | 1.23.2 |
| `org.jsoup:jsoup` | Maven | All versions | 1.23.2 |
| `jsoup` | SUSE:Linux Enterprise High Performance Computing 15 SP4-ESPOS | All versions | 1.23.2-150200.3.14.1 |
| `jsoup` | SUSE:Linux Enterprise High Performance Computing 15 SP4-LTSS | All versions | 1.23.2-150200.3.14.1 |
| `jsoup` | SUSE:Linux Enterprise High Performance Computing 15 SP5-ESPOS | All versions | 1.23.2-150200.3.14.1 |
| `jsoup` | SUSE:Linux Enterprise High Performance Computing 15 SP5-LTSS | All versions | 1.23.2-150200.3.14.1 |
| `jsoup` | SUSE:Linux Enterprise Module for Development Tools 15 SP7 | All versions | 1.23.2-150200.3.14.1 |
| `jsoup` | SUSE:Linux Enterprise Server 15 SP4-LTSS | All versions | 1.23.2-150200.3.14.1 |
| `jsoup` | SUSE:Linux Enterprise Server 15 SP5-LTSS | All versions | 1.23.2-150200.3.14.1 |
| `jsoup` | SUSE:Linux Enterprise Server 15 SP6-LTSS | All versions | 1.23.2-150200.3.14.1 |
| `jsoup` | SUSE:Linux Enterprise Server 16.0 | All versions | 1.23.2-160000.1.1 |
| `jsoup` | SUSE:Linux Enterprise Server 16.0 | All versions | 1.23.2-160000.1.1 |
| `jsoup` | SUSE:Linux Enterprise Server for SAP Applications 15 SP4 | All versions | 1.23.2-150200.3.14.1 |
| `jsoup` | SUSE:Linux Enterprise Server for SAP Applications 15 SP5 | All versions | 1.23.2-150200.3.14.1 |
| `jsoup` | SUSE:Linux Enterprise Server for SAP Applications 15 SP6 | All versions | 1.23.2-150200.3.14.1 |
| `jsoup` | SUSE:Linux Enterprise Server for SAP applications 16.0 | All versions | 1.23.2-160000.1.1 |
| `jsoup` | SUSE:Linux Enterprise Server for SAP applications 16.0 | All versions | 1.23.2-160000.1.1 |
| `jsoup` | openSUSE:Leap 16.0 | All versions | 1.23.2-160000.1.1 |
| `re2j` | openSUSE:Leap 16.0 | All versions | 1.8-160000.1.1 |
| `jsoup` | openSUSE:Tumbleweed | All versions | 1.23.2-1.1 |

## How do I fix CVE-2026-75140?

Upgrade org.jsoup:jsoup to 1.23.2 or later.

## Is CVE-2026-75140 being exploited?

There is no known exploitation of CVE-2026-75140 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-75140 and fix it if it is affected.

What it is: CVE-2026-75140 is a high-severity denial of service vulnerability in jhy soup, published on 20 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-75140 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jsoup:jsoup (Maven): affected all versions; fixed in 1.23.2
- org.jsoup:jsoup (Maven): affected all versions; fixed in 1.23.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-75140/ (Markdown: https://insights.sbomify.com/CVE-2026-75140/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-75140
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-75140
- OSV: https://osv.dev/vulnerability/CVE-2026-75140

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-75140/
Summaries are generated and may contain mistakes; the official description above is the record.
