# CVE-2026-75156: Auth bypass in Apache Airflow FAB provider

> Attackers can bypass authentication in Apache Airflow by using tokens from any Azure tenant, gaining unauthorized access to the UI.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Sep 2026
- **Updated:** 16 Sep 2026
- **Also known as:** CLEANSTART-2026-TQ94718, GHSA-vrqc-p75r-25rv

## What is CVE-2026-75156?

CVE-2026-75156 is a critical authentication bypass vulnerability in Apache Airflow FAB provider, published on 8 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Apache Airflow FAB provider versions 3.7.3 through 3.8.0 do not validate the issuer or audience of Azure AD `id_token`s during OAuth login. Deployments are affected only when the FAB auth manager is configured with Azure AD as an OAuth provider. Because the signing keys are fetched from Microsoft's **multi-tenant** JWKS endpoint, an `id_token` minted in *any* Azure tenant — including one the attacker creates — passes signature verification, and the username and role assignments are then read from that attacker-controlled token. Anyone able to register an Azure tenant can therefore authenticate to the Airflow UI with no prior access to the deployment.

The fix for **CVE-2026-59243** was incomplete, and this advisory closes the remaining gap: that fix made the provider verify the `id_token` signature, but did not add issuer or audience checks. Operators who already applied the CVE-2026-59243 fix are **still affected and must upgrade again** — 3.7.3 is the release that shipped that fix, so every version containing it falls inside this affected range. Upgrade to apache-airflow-providers-fab `3.8.1` or later.

Weakness: CWE-346 (Origin Validation Error)

## Which versions are affected by CVE-2026-75156?

It affects 1 product.


Products: Apache Apache-Airflow-Providers-Fab.

## How do I fix CVE-2026-75156?

Upgrade to a fixed version.

## Is CVE-2026-75156 being exploited?

There is no known exploitation of CVE-2026-75156 in the wild and no public exploit code.

## Other vulnerabilities in Apache Airflow FAB provider

- [CVE-2026-82311](https://insights.sbomify.com/CVE-2026-82311/): Security feature bypass in Apache Airflow FAB provider (critical 9.8)
- [CVE-2026-59243](https://insights.sbomify.com/CVE-2026-59243/): Auth bypass in Apache Airflow FAB provider (critical 9.8)
- [CVE-2024-42447](https://insights.sbomify.com/CVE-2024-42447/): Apache Airflow Providers FAB: FAB provider 1.2.1 and 1.2.0 did not let user to logout for Airflow (critical 9.8)
- [CVE-2026-86462](https://insights.sbomify.com/CVE-2026-86462/): Apache Airflow FAB provider: FAB Admin password PATCH does not invalidate database-backed sessions (critical 9.1)
- [CVE-2026-86466](https://insights.sbomify.com/CVE-2026-86466/): Apache Airflow FAB provider: FAB Authentik provider: id_token issuer/audience not validated (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-75156 and fix it if it is affected.

What it is: CVE-2026-75156 is a critical authentication bypass vulnerability in Apache Airflow FAB provider, published on 8 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-75156 in the wild and no public exploit code.

Affected product: Apache Airflow FAB provider. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-75156/ (Markdown: https://insights.sbomify.com/CVE-2026-75156/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-75156
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-75156
- OSV: https://osv.dev/vulnerability/CVE-2026-75156

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-75156/
Summaries are generated and may contain mistakes; the official description above is the record.
