# CVE-2026-75157: Missing authorization in Apache Airflow

> Authenticated users with read access can delete queued asset events, suppressing scheduling for workflows they cannot edit.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Sep 2026
- **Updated:** 22 Sep 2026
- **Also known as:** BIT-airflow-2026-75157, GHSA-gmw9-258q-r8gm

## What is CVE-2026-75157?

CVE-2026-75157 is a high-severity missing authorization vulnerability in Apache Airflow, published on 18 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Apache Airflow's asset queued-events DELETE endpoints checked the caller's Dag-axis permission with `READ` instead of `EDIT`. Any authenticated user who could read a Dag could therefore delete that Dag's queued asset events, silently suppressing asset-triggered scheduling for it — a state-changing action gated on a read-only permission. Deployments are affected whenever asset-triggered scheduling is in use and Dag read access is granted more widely than Dag edit access, which is the normal RBAC arrangement; no special configuration is required. Upgrade to apache-airflow 3.3.2 or later.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2026-75157?

1 open source package ship an affected version, including airflow.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `airflow` | Bitnami | All versions | 3.3.2 |

## How do I fix CVE-2026-75157?

Upgrade airflow to 3.3.2 or later.

## Is CVE-2026-75157 being exploited?

There is no known exploitation of CVE-2026-75157 in the wild and no public exploit code.

Public exploit code:

- Standalone authorized universal HTTP PoC for CVE-2026-75157 (github_poc): https://github.com/licitrasimone/cve-2026-75157-poc

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-75157 and fix it if it is affected.

What it is: CVE-2026-75157 is a high-severity missing authorization vulnerability in Apache Airflow, published on 18 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-75157 in the wild and no public exploit code.

Affected packages and fixed versions:
- airflow (Bitnami): affected all versions; fixed in 3.3.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-75157/ (Markdown: https://insights.sbomify.com/CVE-2026-75157/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-75157
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-75157
- OSV: https://osv.dev/vulnerability/CVE-2026-75157

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-75157/
Summaries are generated and may contain mistakes; the official description above is the record.
