# CVE-2026-75158: Apache Airflow: Assets events API returns asset events for every Dag with no per-Dag authorization filter

> Authenticated users can enumerate asset events and hidden DAG metadata across all DAGs due to missing per-DAG authorization filters in the API.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Sep 2026
- **Updated:** 21 Sep 2026
- **Also known as:** BIT-airflow-2026-75158, CLEANSTART-2026-CM94028, GHSA-pfr9-65p3-w9r9, PYSEC-2026-3988

## What is CVE-2026-75158?

CVE-2026-75158 is a medium-severity missing authorization vulnerability in Apache Airflow, published on 21 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Apache Airflow's `/assets/events` API returned asset events for every Dag in the deployment, with no filter restricting them to the Dags the caller is authorized to read. Any authenticated user holding asset-read access could therefore enumerate asset events — including the source Dag ID, task ID, run ID and event timestamps — for Dags they have no permission to see. Because the filter was also absent from the count query, `total_entries` and pagination disclosed the existence of hidden Dags even without inspecting individual rows. Deployments are affected whenever per-Dag access control is used to separate teams or tenants; no special configuration is required. Upgrade to apache-airflow 3.3.2 or later.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2026-75158?

2 open source packages ship an affected version, including apache-airflow and airflow. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apache-airflow` | PyPI | All versions | 3.3.2 |
| `airflow` | Bitnami | All versions | 3.3.2 |

Products: Apache Airflow.

## How do I fix CVE-2026-75158?

Upgrade apache-airflow to 3.3.2 or later.

## Is CVE-2026-75158 being exploited?

There is no known exploitation of CVE-2026-75158 in the wild and no public exploit code.

## Other vulnerabilities in Apache Airflow

- [CVE-2020-13927](https://insights.sbomify.com/CVE-2020-13927/): Apache Airflow's Experimental API Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2020-11978](https://insights.sbomify.com/CVE-2020-11978/): Apache Airflow Command Injection (high 8.8, exploited in the wild)
- [CVE-2026-33264](https://insights.sbomify.com/CVE-2026-33264/): Apache Airflow: DAG author RCE on webserver via unrestricted import_string() in BaseSerialization.deserialize() (critical 9.8)
- [CVE-2023-25754](https://insights.sbomify.com/CVE-2023-25754/): Apache Airflow: Privilege escalation using airflow logs (critical 9.8)
- [CVE-2023-22884](https://insights.sbomify.com/CVE-2023-22884/): Apache Airflow, Apache Airflow MySQL Provider: Arbitrary file read via MySQL provider in Apache Airflow (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-75158 and fix it if it is affected.

What it is: CVE-2026-75158 is a medium-severity missing authorization vulnerability in Apache Airflow, published on 21 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-75158 in the wild and no public exploit code.

Affected packages and fixed versions:
- apache-airflow (PyPI): affected all versions; fixed in 3.3.2
- airflow (Bitnami): affected all versions; fixed in 3.3.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-75158/ (Markdown: https://insights.sbomify.com/CVE-2026-75158/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-75158
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-75158
- OSV: https://osv.dev/vulnerability/CVE-2026-75158

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-75158/
Summaries are generated and may contain mistakes; the official description above is the record.
