# CVE-2026-75514: BunkerWeb: rDNS bypass via missing forward-confirmation (FCrDNS) in blacklist, greylist, and antibot

> Attackers can bypass BunkerWeb's blacklist, greylist, and antibot protections by spoofing reverse DNS records without forward confirmation.

- **Severity:** Medium 5.9 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 20 Aug 2026
- **Updated:** 20 Aug 2026
- **Also known as:** GHSA-q54j-5484-pvjm

## What is CVE-2026-75514?

CVE-2026-75514 is a medium-severity vulnerability in bunkerity bunkerweb, published on 20 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

BunkerWeb is an open-source, next-generation Web Application Firewall. Prior to 1.6.13, the blacklist, greylist, and antibot modules in src/common/core/blacklist/blacklist.lua, src/common/core/greylist/greylist.lua, and src/common/core/antibot/antibot.lua trust PTR suffix matches in IGNORE_RDNS, GREYLIST_RDNS, and ANTIBOT_IGNORE_RDNS without using get_ips to confirm that the hostname resolves to the client address. An unauthenticated remote attacker who controls a PTR record can spoof a trusted suffix to bypass rDNS-based blacklisting, gain greylist treatment, or skip an antibot challenge. This issue is fixed in version 1.6.13.

Weakness: CWE-350 (Reliance on Reverse DNS Resolution for a Security-Critical Action)

## Which versions are affected by CVE-2026-75514?


## How do I fix CVE-2026-75514?

No fix has been published for CVE-2026-75514 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-75514 being exploited?

There is no known exploitation of CVE-2026-75514 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-75514 and fix it if it is affected.

What it is: CVE-2026-75514 is a medium-severity vulnerability in bunkerity bunkerweb, published on 20 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-75514 in the wild and no public exploit code.

Affected product: bunkerity bunkerweb. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-75514/ (Markdown: https://insights.sbomify.com/CVE-2026-75514/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-75514
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-75514
- OSV: https://osv.dev/vulnerability/CVE-2026-75514

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-75514/
Summaries are generated and may contain mistakes; the official description above is the record.
