# CVE-2026-75524: OpenReception: race condition in add-to-tunnel and create-new-client allows overlapping appointments for one agent


- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Fix available:** No
- **Published:** 23 Oct 2026
- **Updated:** 29 Oct 2026
- **Also known as:** GHSA-q452-m9pf-qj9j

## What is CVE-2026-75524?

CVE-2026-75524 is a medium-severity vulnerability in open-reception appointment-booking-software, published on 23 Oct 2026. 

### Official description

OpenReception's appointment booking software provides an end-to-end encrypted appointment booking platform. Prior to version 2.2.2, an attacker overbooks an agent, placing multiple appointments into a single time slot that the system is designed to keep exclusive. The number of overlapping appointments equals the number of concurrent requests, and one booking token is enough because the token is consumed after the insert. This results in the integrity of the booking-calendar breaking and availability being denied to other clients. This issue has been patched in version 2.2.2.

Weakness: CWE-367 (Time-of-check Time-of-use (TOCTOU) Race Condition)

## Which versions are affected by CVE-2026-75524?


## How do I fix CVE-2026-75524?

No fix has been published for CVE-2026-75524 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-75524 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-75524 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-75524 and fix it if it is affected.

What it is: CVE-2026-75524 is a medium-severity vulnerability in open-reception appointment-booking-software, published on 23 Oct 2026. 
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-75524 exists.

Affected product: open-reception appointment-booking-software. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-75524/ (Markdown: https://insights.sbomify.com/CVE-2026-75524/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-75524
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-75524
- OSV: https://osv.dev/vulnerability/CVE-2026-75524

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-75524/
Summaries are generated and may contain mistakes; the official description above is the record.
