CVE-2026-75594 Kirby: Access to image files and limited access to JSON files outside of the site root via path traversal in the media handling
Attackers can traverse directories to read arbitrary JSON files and delete job files via crafted media requests on specific server configurations.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-75594?
CVE-2026-75594 is a high-severity path traversal vulnerability in getkirby kirby, published on 31 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Kirby is an open-source content management system. Prior to 4.9.5 and 5.5.2, depending on the release line, Kirby's media handler in src/Cms/Media.php allowed Kirby\Cms\Media::thumb() to append a path-bearing filename to a validated parent media directory. On nginx, PHP's built-in server, or Apache with AllowEncodedSlashes enabled, a remote attacker could submit encoded slash characters such as %2f in the filename and traverse outside the parent's media directory. Differences between responses for existing and nonexistent thumbnail configurations disclosed whether an arbitrary .json file existed, and a .json file containing a valid filename key could cause the referenced image to be returned and the job file to be deleted. The related file::version path in src/Filesystem/Asset.php also accepted ../ sequences outside the intended index root. This issue is fixed in versions 4.9.5 and 5.5.2.
Weakness: CWE-22
Which versions are affected by CVE-2026-75594?
4 open source packages ship an affected version, including getkirby/cms.
| Package | Affected | Fixed in |
|---|---|---|
getkirby/cms Packagist | All versions | 4.9.5 |
getkirby/cms Packagist | All versions | 4.9.5 |
getkirby/cms Packagist | From 5.0.0 | 5.5.2 |
getkirby/cms Packagist | From 5.0.0 | 5.5.2 |
How do I fix CVE-2026-75594?
Upgrade getkirby/cms to a fixed version for your release line: 4.9.5 or 5.5.2.
Upgrade, and resolve every user-supplied path against an allowed base folder before opening it. More about Path traversal.
Is CVE-2026-75594 being exploited?
There is no known exploitation of CVE-2026-75594 in the wild and no public exploit code.
Sources
Also known as GHSA-9vx2-j98c-p72w.