{"answers":{"affected":"1 open source package ship an affected version, including ash_ai.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-75760 exists.","fix":"Upgrade ash_ai to 1.0.0 or later.","what":"CVE-2026-75760 is a high-severity vulnerability in ash-project ash_ai, published on 31 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-75760 and fix it if it is affected.\n\nWhat it is: CVE-2026-75760 is a high-severity vulnerability in ash-project ash_ai, published on 31 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-75760 exists.\n\nAffected packages and fixed versions:\n- ash_ai (Hex): affected from 0.1.0; fixed in 1.0.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-75760/ (Markdown: https://insights.sbomify.com/CVE-2026-75760/index.md)","id":"CVE-2026-75760","markdown":"https://insights.sbomify.com/CVE-2026-75760/index.md","name":"CVE-2026-75760","record":{"aliases":["EEF-CVE-2026-75760","GHSA-p5cr-mmmf-6w39"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Elixir Ash AI library","requires_auth":"low_privilege","summary":"Attackers can trigger embedding provider errors to leak sensitive credentials and request details in user-facing error messages.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"EEF","cpe":[],"cvss":{"score":7.1,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-209","name":"Generation of Error Message Containing Sensitive Information"}],"description":"Generation of Error Message Containing Sensitive Information vulnerability in ash-project ash_ai discloses provider request state and credentials in a user-facing validation error.\n\nIn AshAi.Changes.Vectorize, when the embedding provider call fails the change added a changeset error whose message inspected the raw error term (An error occurred while generating embeddings: #{inspect(error)}). A plain-string add_error produces an Ash.Error.Changes.InvalidChanges in the :invalid class, which AshJsonApi and AshGraphql render back to the caller. The embedding client's error term is not sanitized, so it can carry the request URL, the provider response body, and, for HTTP clients that keep the request in the error struct, the outbound Authorization header with the provider API key. Failures are attacker-reachable via oversized or malformed vectorized content. The fix logs the raw error and returns a generic message.\n\nThis issue affects ash_ai: from 0.1.0 before 1.0.0.","ecosystems":["Hex"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"AshAi vectorize change leaks raw embedding-provider errors, including credentials, in a user-facing error","id":"CVE-2026-75760","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Hex","product":null,"products":[],"type":"information_disclosure","year":"2026"},"n_packages":1,"n_references":4,"next":{"headline":"Substance3D - Painter | Heap-based Buffer Overflow (CWE-122)","id":"CVE-2026-75766"},"packages":[{"ecosystem":"Hex","fixed":["1.0.0"],"introduced":["0.1.0"],"last_affected":[],"package":"ash_ai","purl":"pkg:hex/ash_ai","source":"EEF-CVE-2026-75760"}],"prev":{"headline":"Encrypted ID token or JARM response accepted without a nested signature in erlef oidcc","id":"CVE-2026-75759"},"products":["ash_ai"],"published":"2026-08-31","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"Erlang Ecosystem Foundation","prefix":"EEF"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-08-31","vendors":["ash-project"]},"summary":"Attackers can trigger embedding provider errors to leak sensitive credentials and request details in user-facing error messages.","url":"https://insights.sbomify.com/CVE-2026-75760/"}