# CVE-2026-75760: AshAi vectorize change leaks raw embedding-provider errors, including credentials, in a user-facing error

> Attackers can trigger embedding provider errors to leak sensitive credentials and request details in user-facing error messages.

- **Severity:** High 7.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 31 Aug 2026
- **Updated:** 31 Aug 2026
- **Also known as:** EEF-CVE-2026-75760, GHSA-p5cr-mmmf-6w39

## What is CVE-2026-75760?

CVE-2026-75760 is a high-severity vulnerability in ash-project ash_ai, published on 31 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Generation of Error Message Containing Sensitive Information vulnerability in ash-project ash_ai discloses provider request state and credentials in a user-facing validation error.

In AshAi.Changes.Vectorize, when the embedding provider call fails the change added a changeset error whose message inspected the raw error term (An error occurred while generating embeddings: #{inspect(error)}). A plain-string add_error produces an Ash.Error.Changes.InvalidChanges in the :invalid class, which AshJsonApi and AshGraphql render back to the caller. The embedding client's error term is not sanitized, so it can carry the request URL, the provider response body, and, for HTTP clients that keep the request in the error struct, the outbound Authorization header with the provider API key. Failures are attacker-reachable via oversized or malformed vectorized content. The fix logs the raw error and returns a generic message.

This issue affects ash_ai: from 0.1.0 before 1.0.0.

Weakness: CWE-209 (Generation of Error Message Containing Sensitive Information)

## Which versions are affected by CVE-2026-75760?

1 open source package ship an affected version, including ash_ai.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ash_ai` | Hex | From 0.1.0 | 1.0.0 |

## How do I fix CVE-2026-75760?

Upgrade ash_ai to 1.0.0 or later.

## Is CVE-2026-75760 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-75760 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-75760 and fix it if it is affected.

What it is: CVE-2026-75760 is a high-severity vulnerability in ash-project ash_ai, published on 31 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-75760 exists.

Affected packages and fixed versions:
- ash_ai (Hex): affected from 0.1.0; fixed in 1.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-75760/ (Markdown: https://insights.sbomify.com/CVE-2026-75760/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-75760
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-75760
- OSV: https://osv.dev/vulnerability/CVE-2026-75760

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-75760/
Summaries are generated and may contain mistakes; the official description above is the record.
