# CVE-2026-75802: Apache Wicket: XSS in AjaxEditableLabel and its subclasses via IChoiceRenderer and defaultNullLabel

> Attackers can inject scripts via unescaped label values in Apache Wicket components, allowing code execution in victim browsers.

- **Severity:** Medium 5.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N/U:Amber`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 31 Aug 2026
- **Updated:** 31 Aug 2026
- **Also known as:** GHSA-hx44-pxvx-pqrv

## What is CVE-2026-75802?

CVE-2026-75802 is a medium-severity cross-site scripting vulnerability in Apache Wicket, published on 31 Aug 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

AjaxEditableChoiceLabel in wicket-extensions, when constructed with a non-null IChoiceRenderer, writes the display value obtained from that renderer into the label's markup without applying the HTML escaping Wicket performs by default for component model values. An attacker who can influence the choice or model data rendered by such a label can inject HTML or script that executes in the browser of any user who views the page. The same value is correctly escaped when the component's dropdown editor renders it as an option, so only the label rendering is affected.

AjaxEditableLabel, AjaxEditableChoiceLabel and AjaxEditableMultiLineLabel write the value returned by the protected defaultNullLabel() method into the label's markup the same way when the component's model is empty, while the model value they show otherwise is escaped. The default implementation returns a constant, so an application is affected where it overrides that method and returns a value an attacker can influence.

Neither value could be escaped by configuration, because escapeModelStrings had no effect on any of the three components: it is read by the label they render with rather than by the component itself, and nothing carried the setting across.

This issue affects Apache Wicket: from 8.0.0 through 8.18.0, from 9.0.0 through 9.23.0, from 10.0.0 through 10.10.0. Older, unsupported releases are also affected; the display value from the renderer since 6.22.0 and the null label since 1.4.0. Users are recommended to upgrade to version 8.19.0, 9.24.0 or 10.11.0, which fix the issue.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-75802?

It affects 1 product.


Products: Apache Wicket.

## How do I fix CVE-2026-75802?

No fix has been published for CVE-2026-75802 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-75802 being exploited?

There is no known exploitation of CVE-2026-75802 in the wild and no public exploit code.

## Other vulnerabilities in Apache Wicket

- [CVE-2024-36522](https://insights.sbomify.com/CVE-2024-36522/): Apache Wicket: Remote code execution via XSLT injection (critical 9.8)
- [CVE-2026-40010](https://insights.sbomify.com/CVE-2026-40010/): Apache Wicket: possible session fixation using AuthenticatedWebSession (critical 9.1)
- [CVE-2016-6793](https://insights.sbomify.com/CVE-2016-6793/): Deserialization in n/a (critical 9.1)
- [CVE-2016-6806](https://insights.sbomify.com/CVE-2016-6806/): Apache Wicket vulnerable to CSRF attacks (high 8.8)
- [CVE-2026-71257](https://insights.sbomify.com/CVE-2026-71257/): Apache Wicket: Configured file upload limits are not enforced when the multipart request has already been parsed (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-75802 and fix it if it is affected.

What it is: CVE-2026-75802 is a medium-severity cross-site scripting vulnerability in Apache Wicket, published on 31 Aug 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-75802 in the wild and no public exploit code.

Affected product: Apache Wicket. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-75802/ (Markdown: https://insights.sbomify.com/CVE-2026-75802/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-75802
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-75802
- OSV: https://osv.dev/vulnerability/CVE-2026-75802

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-75802/
Summaries are generated and may contain mistakes; the official description above is the record.
