{"answers":{"affected":"2 open source packages ship an affected version, including getgrav/grav.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-75827 exists.","fix":"Upgrade getgrav/grav to 2.0.15 or later.","what":"CVE-2026-75827 is a critical code injection vulnerability in getgrav grav, published on 18 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-75827 and fix it if it is affected.\n\nWhat it is: CVE-2026-75827 is a critical code injection vulnerability in getgrav grav, published on 18 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-75827 exists.\n\nAffected packages and fixed versions:\n- getgrav/grav (Packagist): affected all versions; fixed in 2.0.15\n- getgrav/grav (Packagist): affected all versions; fixed in 2.0.15\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-75827/ (Markdown: https://insights.sbomify.com/CVE-2026-75827/index.md)","id":"CVE-2026-75827","markdown":"https://insights.sbomify.com/CVE-2026-75827/index.md","name":"CVE-2026-75827","record":{"aliases":["GHSA-f8wv-xp27-6gq7"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Grav CMS","requires_auth":"none","summary":"Attackers with page-edit access can inject PHP code via error_log to achieve remote code execution in Grav CMS.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulnCheck","cpe":[],"cvss":{"score":9.3,"severity":"critical","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-94","name":"Improper Control of Generation of Code"}],"description":"Grav before 2.0.15 contains an arbitrary file write vulnerability in the Blueprint dynamic-data bare-function validation that uses an incomplete denylist instead of a positive allowlist. Attackers with page-edit or blueprint-config access can invoke the error_log function through a data directive to append PHP payloads to web-accessible files, achieving remote code execution.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":"2026-09-18","github_poc":1,"max_poc_stars":0,"metasploit":0,"nuclei":0,"refs":[{"date":"2026-09-18T17:57:47Z","kind":"github_poc","ref":"https://github.com/abraxas/CVE-2026-75827","stars":0,"title":"CVE-2026-75827 - getgrav - High 8.8 - Unauthenticated GET /poc-form - Arbitrary File Write"}],"tier":"weaponised"},"has_fix":true,"headline":"Grav before 2.0.15 Arbitrary File Write via error_log","id":"CVE-2026-75827","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"code_injection","year":"2026"},"n_packages":2,"n_references":2,"next":{"headline":"Grav before 2.0.15 Stored XSS via detectXss() Quote Bypass","id":"CVE-2026-75828"},"packages":[{"ecosystem":"Packagist","fixed":["2.0.15"],"introduced":["0"],"last_affected":[],"package":"getgrav/grav","purl":null,"source":"GHSA-f8wv-xp27-6gq7"},{"ecosystem":"Packagist","fixed":["2.0.15"],"introduced":["0"],"last_affected":[],"package":"getgrav/grav","purl":"pkg:composer/getgrav/grav","source":"GHSA-f8wv-xp27-6gq7"}],"prev":{"headline":"Teltonika Command Injection in Backup function","id":"CVE-2026-75826"},"products":["grav"],"published":"2026-08-18","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-10-08","vendors":["getgrav"]},"summary":"Attackers with page-edit access can inject PHP code via error_log to achieve remote code execution in Grav CMS.","url":"https://insights.sbomify.com/CVE-2026-75827/"}