# CVE-2026-75827: Grav before 2.0.15 Arbitrary File Write via error_log

> Attackers with page-edit access can inject PHP code via error_log to achieve remote code execution in Grav CMS.

- **Severity:** Critical 9.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Aug 2026
- **Updated:** 8 Oct 2026
- **Also known as:** GHSA-f8wv-xp27-6gq7

## What is CVE-2026-75827?

CVE-2026-75827 is a critical code injection vulnerability in getgrav grav, published on 18 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Grav before 2.0.15 contains an arbitrary file write vulnerability in the Blueprint dynamic-data bare-function validation that uses an incomplete denylist instead of a positive allowlist. Attackers with page-edit or blueprint-config access can invoke the error_log function through a data directive to append PHP payloads to web-accessible files, achieving remote code execution.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2026-75827?

2 open source packages ship an affected version, including getgrav/grav.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `getgrav/grav` | Packagist | All versions | 2.0.15 |
| `getgrav/grav` | Packagist | All versions | 2.0.15 |

## How do I fix CVE-2026-75827?

Upgrade getgrav/grav to 2.0.15 or later.

## Is CVE-2026-75827 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-75827 exists.

Public exploit code:

- CVE-2026-75827 - getgrav - High 8.8 - Unauthenticated GET /poc-form - Arbitrary File Write (github_poc): https://github.com/abraxas/CVE-2026-75827

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-75827 and fix it if it is affected.

What it is: CVE-2026-75827 is a critical code injection vulnerability in getgrav grav, published on 18 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-75827 exists.

Affected packages and fixed versions:
- getgrav/grav (Packagist): affected all versions; fixed in 2.0.15
- getgrav/grav (Packagist): affected all versions; fixed in 2.0.15

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-75827/ (Markdown: https://insights.sbomify.com/CVE-2026-75827/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-75827
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-75827
- OSV: https://osv.dev/vulnerability/CVE-2026-75827

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-75827/
Summaries are generated and may contain mistakes; the official description above is the record.
