# CVE-2026-75830: grav-plugin-api before 1.0.15 Path Traversal via batchCopy

> An authenticated editor can exploit path traversal in the Grav API plugin to write arbitrary files to the server filesystem.

- **Severity:** High 7.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:H/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 18 Aug 2026
- **Updated:** 18 Aug 2026
- **Also known as:** GHSA-r93f-38mc-xpvv

## What is CVE-2026-75830?

CVE-2026-75830 is a high-severity path traversal vulnerability in getgrav grav, published on 18 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

grav-plugin-api (getgrav/grav-plugin-api) versions >= 1.0.0-beta.10 and <= 1.0.14 contain a path traversal vulnerability in the PagesController::batchCopy() method. An incomplete fix for GHSA-qjq4-jp55-4mx2 left the user-controlled 'suffix' parameter (via POST /api/v1/pages/batch) unvalidated. An authenticated user with the api.pages.write permission (editor-level, not super-admin) can supply path traversal sequences (e.g. /../../../) in the suffix parameter to escape the intended user/pages/ directory and write attacker-controlled page content and page media to arbitrary filesystem locations writable by the web server process. The vulnerability is fixed in 1.0.15.

Weakness: CWE-73 (External Control of File Name or Path)

## Which versions are affected by CVE-2026-75830?


## How do I fix CVE-2026-75830?

No fix has been published for CVE-2026-75830 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-75830 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-75830 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-75830 and fix it if it is affected.

What it is: CVE-2026-75830 is a high-severity path traversal vulnerability in getgrav grav, published on 18 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-75830 exists.

Affected product: getgrav grav. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-75830/ (Markdown: https://insights.sbomify.com/CVE-2026-75830/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-75830
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-75830
- OSV: https://osv.dev/vulnerability/CVE-2026-75830

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-75830/
Summaries are generated and may contain mistakes; the official description above is the record.
