{"answers":{"affected":"2 open source packages ship an affected version, including getgrav/grav.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-75831 exists.","fix":"Upgrade getgrav/grav to 2.0.15 or later.","what":"CVE-2026-75831 is a medium-severity cross-site scripting vulnerability in getgrav grav, published on 18 Aug 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-75831 and fix it if it is affected.\n\nWhat it is: CVE-2026-75831 is a medium-severity cross-site scripting vulnerability in getgrav grav, published on 18 Aug 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-75831 exists.\n\nAffected packages and fixed versions:\n- getgrav/grav (Packagist): affected all versions; fixed in 2.0.15\n- getgrav/grav (Packagist): affected all versions; fixed in 2.0.15\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-75831/ (Markdown: https://insights.sbomify.com/CVE-2026-75831/index.md)","id":"CVE-2026-75831","markdown":"https://insights.sbomify.com/CVE-2026-75831/index.md","name":"CVE-2026-75831","record":{"aliases":["GHSA-6qw9-4vv5-jr97"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Grav CMS","requires_auth":"low_privilege","summary":"Attackers can inject malicious scripts via media URLs in Grav CMS, leading to arbitrary code execution in victim sessions.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulnCheck","cpe":[],"cvss":{"score":5.1,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N","version":"4.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Grav before 2.0.15 contains a stored cross-site scripting vulnerability in the audio and video media rendering through the sourceParsedownElement method. The media URL fragment is concatenated unescaped into rawHtml source elements, allowing attackers to inject arbitrary HTML and JavaScript that executes in viewers' sessions.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Grav before 2.0.15 Stored XSS via audio/video source URL","id":"CVE-2026-75831","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2026"},"n_packages":2,"n_references":3,"next":{"headline":"Grav API Plugin before 1.0.14 Authorization Bypass","id":"CVE-2026-75832"},"packages":[{"ecosystem":"Packagist","fixed":["2.0.15"],"introduced":["0"],"last_affected":[],"package":"getgrav/grav","purl":null,"source":"GHSA-6qw9-4vv5-jr97"},{"ecosystem":"Packagist","fixed":["2.0.15"],"introduced":["0"],"last_affected":[],"package":"getgrav/grav","purl":"pkg:composer/getgrav/grav","source":"GHSA-6qw9-4vv5-jr97"}],"prev":{"headline":"grav-plugin-api before 1.0.15 Path Traversal via batchCopy","id":"CVE-2026-75830"},"products":["grav"],"published":"2026-08-18","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-10-08","vendors":["getgrav"]},"summary":"Attackers can inject malicious scripts via media URLs in Grav CMS, leading to arbitrary code execution in victim sessions.","url":"https://insights.sbomify.com/CVE-2026-75831/"}