# CVE-2026-75831: Grav before 2.0.15 Stored XSS via audio/video source URL

> Attackers can inject malicious scripts via media URLs in Grav CMS, leading to arbitrary code execution in victim sessions.

- **Severity:** Medium 5.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 18 Aug 2026
- **Updated:** 8 Oct 2026
- **Also known as:** GHSA-6qw9-4vv5-jr97

## What is CVE-2026-75831?

CVE-2026-75831 is a medium-severity cross-site scripting vulnerability in getgrav grav, published on 18 Aug 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Grav before 2.0.15 contains a stored cross-site scripting vulnerability in the audio and video media rendering through the sourceParsedownElement method. The media URL fragment is concatenated unescaped into rawHtml source elements, allowing attackers to inject arbitrary HTML and JavaScript that executes in viewers' sessions.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-75831?

2 open source packages ship an affected version, including getgrav/grav.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `getgrav/grav` | Packagist | All versions | 2.0.15 |
| `getgrav/grav` | Packagist | All versions | 2.0.15 |

## How do I fix CVE-2026-75831?

Upgrade getgrav/grav to 2.0.15 or later.

## Is CVE-2026-75831 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-75831 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-75831 and fix it if it is affected.

What it is: CVE-2026-75831 is a medium-severity cross-site scripting vulnerability in getgrav grav, published on 18 Aug 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-75831 exists.

Affected packages and fixed versions:
- getgrav/grav (Packagist): affected all versions; fixed in 2.0.15
- getgrav/grav (Packagist): affected all versions; fixed in 2.0.15

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-75831/ (Markdown: https://insights.sbomify.com/CVE-2026-75831/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-75831
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-75831
- OSV: https://osv.dev/vulnerability/CVE-2026-75831

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-75831/
Summaries are generated and may contain mistakes; the official description above is the record.
