CVE-2026-75832 Grav API Plugin before 1.0.14 Authorization Bypass
Attackers with limited API keys can bypass authorization to read and write files in other users' scopes within the Grav CMS.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- None listed
What is CVE-2026-75832?
CVE-2026-75832 is a critical missing authorization vulnerability in getgrav grav, published on 18 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
The Grav API plugin (getgrav/grav-plugin-api, bundled with Grav 2.0) before version 1.0.14 (fixed in 1.0.15) contains a missing authorization vulnerability in BlueprintPathResolver::resolveUserScope(). The method gates the users/<name> scope on the account's raw super-admin ACL flag (access.api.super) instead of validating the presented API key's actual scope. An attacker holding an API key scoped only to api.media.write minted on a super-admin account can bypass the authorization check and, via POST /blueprint-upload or GET /blueprint-files, write a file into another user's scope (in the shared user/accounts/ directory, constrained to image extensions by assertSafeExtension()) and browse that scope's file listing, despite the key not being granted api.users.write.
Weakness: CWE-862
Which versions are affected by CVE-2026-75832?
How do I fix CVE-2026-75832?
No fix has been published for CVE-2026-75832 yet. Limit exposure of the affected software until one is available.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2026-75832 being exploited?
There is no known exploitation of CVE-2026-75832 in the wild and no public exploit code.
Sources
Also known as GHSA-xgr3-7x2w-f8vc.