# CVE-2026-75832: Grav API Plugin before 1.0.14 Authorization Bypass

> Attackers with limited API keys can bypass authorization to read and write files in other users' scopes within the Grav CMS.

- **Severity:** Critical 9.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 18 Aug 2026
- **Updated:** 19 Aug 2026
- **Also known as:** GHSA-xgr3-7x2w-f8vc

## What is CVE-2026-75832?

CVE-2026-75832 is a critical missing authorization vulnerability in getgrav grav, published on 18 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The Grav API plugin (getgrav/grav-plugin-api, bundled with Grav 2.0) before version 1.0.14 (fixed in 1.0.15) contains a missing authorization vulnerability in BlueprintPathResolver::resolveUserScope(). The method gates the users/<name> scope on the account's raw super-admin ACL flag (access.api.super) instead of validating the presented API key's actual scope. An attacker holding an API key scoped only to api.media.write minted on a super-admin account can bypass the authorization check and, via POST /blueprint-upload or GET /blueprint-files, write a file into another user's scope (in the shared user/accounts/ directory, constrained to image extensions by assertSafeExtension()) and browse that scope's file listing, despite the key not being granted api.users.write.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2026-75832?


## How do I fix CVE-2026-75832?

No fix has been published for CVE-2026-75832 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-75832 being exploited?

There is no known exploitation of CVE-2026-75832 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-75832 and fix it if it is affected.

What it is: CVE-2026-75832 is a critical missing authorization vulnerability in getgrav grav, published on 18 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-75832 in the wild and no public exploit code.

Affected product: getgrav grav. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-75832/ (Markdown: https://insights.sbomify.com/CVE-2026-75832/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-75832
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-75832
- OSV: https://osv.dev/vulnerability/CVE-2026-75832

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-75832/
Summaries are generated and may contain mistakes; the official description above is the record.
