{"answers":{"affected":"2 open source packages ship an affected version, including getgrav/grav.","exploited":"There is no known exploitation of CVE-2026-75834 in the wild and no public exploit code.","fix":"Upgrade getgrav/grav to 2.0.14 or later.","what":"CVE-2026-75834 is a medium-severity cross-site scripting vulnerability in getgrav grav, published on 18 Aug 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-75834 and fix it if it is affected.\n\nWhat it is: CVE-2026-75834 is a medium-severity cross-site scripting vulnerability in getgrav grav, published on 18 Aug 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2026-75834 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- getgrav/grav (Packagist): affected all versions; fixed in 2.0.14\n- getgrav/grav (Packagist): affected all versions; fixed in 2.0.14\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-75834/ (Markdown: https://insights.sbomify.com/CVE-2026-75834/index.md)","id":"CVE-2026-75834","markdown":"https://insights.sbomify.com/CVE-2026-75834/index.md","name":"CVE-2026-75834","record":{"aliases":["GHSA-q2j8-x8hf-63ch"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Grav CMS","requires_auth":"low_privilege","summary":"An authenticated attacker can store malicious JavaScript in Grav CMS pages by bypassing XSS filters with invalid UTF-8 bytes, leading to execution in visitors' browsers.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulnCheck","cpe":[],"cvss":{"score":5.1,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N","version":"4.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Grav before 2.0.14 contains a stored cross-site scripting vulnerability in the Security::detectXss() function (system/src/Grav/Common/Security.php). All XSS detection patterns use the PCRE /u (UTF-8) modifier, so a single invalid UTF-8 byte anywhere in page content causes preg_match() to return false for every pattern, silently bypassing the save-time XSS safety gate (Validation::checkSafety()). An authenticated attacker with page-edit permissions (without the security.xss_whitelist privilege) can store malicious JavaScript that executes in the browser of a visitor who views the affected page.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Grav before 2.0.14 Stored XSS via Invalid UTF-8 Byte","id":"CVE-2026-75834","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2026"},"n_packages":2,"n_references":2,"next":{"headline":"Grav API Plugin before 1.0.14 Missing Authorization","id":"CVE-2026-75835"},"packages":[{"ecosystem":"Packagist","fixed":["2.0.14"],"introduced":["0"],"last_affected":[],"package":"getgrav/grav","purl":null,"source":"GHSA-q2j8-x8hf-63ch"},{"ecosystem":"Packagist","fixed":["2.0.14"],"introduced":["0"],"last_affected":[],"package":"getgrav/grav","purl":"pkg:composer/getgrav/grav","source":"GHSA-q2j8-x8hf-63ch"}],"prev":{"headline":"Grav API Plugin Open Redirect via Backslash Bypass","id":"CVE-2026-75833"},"products":["grav"],"published":"2026-08-18","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-10-08","vendors":["getgrav"]},"summary":"An authenticated attacker can store malicious JavaScript in Grav CMS pages by bypassing XSS filters with invalid UTF-8 bytes, leading to execution in visitors' browsers.","url":"https://insights.sbomify.com/CVE-2026-75834/"}