# CVE-2026-75834: Grav before 2.0.14 Stored XSS via Invalid UTF-8 Byte

> An authenticated attacker can store malicious JavaScript in Grav CMS pages by bypassing XSS filters with invalid UTF-8 bytes, leading to execution in visitors' browsers.

- **Severity:** Medium 5.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 18 Aug 2026
- **Updated:** 8 Oct 2026
- **Also known as:** GHSA-q2j8-x8hf-63ch

## What is CVE-2026-75834?

CVE-2026-75834 is a medium-severity cross-site scripting vulnerability in getgrav grav, published on 18 Aug 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Grav before 2.0.14 contains a stored cross-site scripting vulnerability in the Security::detectXss() function (system/src/Grav/Common/Security.php). All XSS detection patterns use the PCRE /u (UTF-8) modifier, so a single invalid UTF-8 byte anywhere in page content causes preg_match() to return false for every pattern, silently bypassing the save-time XSS safety gate (Validation::checkSafety()). An authenticated attacker with page-edit permissions (without the security.xss_whitelist privilege) can store malicious JavaScript that executes in the browser of a visitor who views the affected page.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-75834?

2 open source packages ship an affected version, including getgrav/grav.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `getgrav/grav` | Packagist | All versions | 2.0.14 |
| `getgrav/grav` | Packagist | All versions | 2.0.14 |

## How do I fix CVE-2026-75834?

Upgrade getgrav/grav to 2.0.14 or later.

## Is CVE-2026-75834 being exploited?

There is no known exploitation of CVE-2026-75834 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-75834 and fix it if it is affected.

What it is: CVE-2026-75834 is a medium-severity cross-site scripting vulnerability in getgrav grav, published on 18 Aug 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-75834 in the wild and no public exploit code.

Affected packages and fixed versions:
- getgrav/grav (Packagist): affected all versions; fixed in 2.0.14
- getgrav/grav (Packagist): affected all versions; fixed in 2.0.14

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-75834/ (Markdown: https://insights.sbomify.com/CVE-2026-75834/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-75834
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-75834
- OSV: https://osv.dev/vulnerability/CVE-2026-75834

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-75834/
Summaries are generated and may contain mistakes; the official description above is the record.
