# CVE-2026-75839: ArcadeDB before 26.8.1 Information Disclosure via Cluster Endpoints

> Authenticated users in ArcadeDB HA clusters can access cluster endpoints to enumerate database names and metadata, leading to cross-database information disclosure.

- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 18 Aug 2026
- **Updated:** 18 Aug 2026
- **Also known as:** GHSA-5g3q-578q-gf3m, GHSA-79wq-w74x-74ch

## What is CVE-2026-75839?

CVE-2026-75839 is a medium-severity vulnerability in ArcadeData arcadedb, published on 18 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

ArcadeDB (com.arcadedb:arcadedb-server) versions <= 26.7.3 contain an insecure direct object reference (IDOR) vulnerability in the Raft cluster-info endpoints (GetClusterHandler and PostBootstrapStateHandler), which authenticate but do not authorize access. On an ArcadeDB HA cluster (only reachable when arcadedb.ha.enabled is set and the ha-raft module is loaded), any authenticated user — including one granted access to only one database or none — can enumerate the full server database registry and retrieve per-database metadata such as database names, last transaction IDs, bootstrap fingerprints, and peer/leader cluster topology, resulting in cross-database information disclosure. Fixed in 26.8.1.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2026-75839?


## How do I fix CVE-2026-75839?

No fix has been published for CVE-2026-75839 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-75839 being exploited?

There is no known exploitation of CVE-2026-75839 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-75839 and fix it if it is affected.

What it is: CVE-2026-75839 is a medium-severity vulnerability in ArcadeData arcadedb, published on 18 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-75839 in the wild and no public exploit code.

Affected product: ArcadeData arcadedb. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-75839/ (Markdown: https://insights.sbomify.com/CVE-2026-75839/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-75839
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-75839
- OSV: https://osv.dev/vulnerability/CVE-2026-75839

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-75839/
Summaries are generated and may contain mistakes; the official description above is the record.
