# CVE-2026-75856: CodeWhale before 0.8.64 SSRF Bypass via DNS Pinning TOCTOU

> Attackers can bypass SSRF protections via DNS pinning TOCTOU flaws to access internal network resources.

- **Severity:** Critical 9.2 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:H/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Aug 2026
- **Updated:** 18 Aug 2026
- **Also known as:** GHSA-6v2g-fpxh-pmmh

## What is CVE-2026-75856?

CVE-2026-75856 is a critical server-side request forgery vulnerability in Hmbown CodeWhale, published on 18 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

CodeWhale before 0.8.64 contains a server-side request forgery bypass vulnerability in DNS pinning logic that fails to prevent time-of-check-time-of-use attacks. Attackers can manipulate DNS responses to fail initial resolution checks and succeed on secondary requests, allowing requests to internal IP addresses and bypassing SSRF mitigations.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2026-75856?

8 open source packages ship an affected version, including codewhale-tui, deepseek-tui and codewhale.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `codewhale-tui` | crates.io | From 0.8.41 | 0.8.64 |
| `codewhale-tui` | crates.io | From 0.8.41 | 0.8.64 |
| `deepseek-tui` | crates.io | From 0.8.5 to 0.8.41 | None |
| `deepseek-tui` | crates.io | From 0.8.5 to 0.8.41 | None |
| `codewhale` | npm | From 0.8.41 | 0.8.64 |
| `codewhale` | npm | From 0.8.41 | 0.8.64 |
| `deepseek-tui` | npm | From 0.8.5 | 0.8.41 |
| `deepseek-tui` | npm | From 0.8.5 | 0.8.41 |

## How do I fix CVE-2026-75856?

Upgrade codewhale-tui to 0.8.64 or later.

## Is CVE-2026-75856 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-75856 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-75856 and fix it if it is affected.

What it is: CVE-2026-75856 is a critical server-side request forgery vulnerability in Hmbown CodeWhale, published on 18 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-75856 exists.

Affected packages and fixed versions:
- codewhale-tui (crates.io): affected from 0.8.41; fixed in 0.8.64
- codewhale-tui (crates.io): affected from 0.8.41; fixed in 0.8.64
- deepseek-tui (crates.io): affected from 0.8.5 up to 0.8.41; no fix listed
- deepseek-tui (crates.io): affected from 0.8.5 up to 0.8.41; no fix listed
- codewhale (npm): affected from 0.8.41; fixed in 0.8.64
- codewhale (npm): affected from 0.8.41; fixed in 0.8.64
- deepseek-tui (npm): affected from 0.8.5; fixed in 0.8.41
- deepseek-tui (npm): affected from 0.8.5; fixed in 0.8.41

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-75856/ (Markdown: https://insights.sbomify.com/CVE-2026-75856/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-75856
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-75856
- OSV: https://osv.dev/vulnerability/CVE-2026-75856

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-75856/
Summaries are generated and may contain mistakes; the official description above is the record.
