CVE-2026-75857 CodeWhale before 0.8.64 Privilege Escalation via exec_shell_interact
Attackers can execute arbitrary commands with elevated privileges by injecting instructions into an AI coding assistant's interactive shell tool.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Local or same network only
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2026-75857?
CVE-2026-75857 is a high-severity vulnerability in Hmbown CodeWhale, published on 18 Aug 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Official description
CodeWhale versions >= 0.3.10 and < 0.8.64 (published as deepseek-tui >= 0.3.10 and < 0.8.41 on npm and 0.3.10 through 0.8.41 on crates.io, and as codewhale / codewhale-tui >= 0.8.41 and < 0.8.64) contain a vulnerability in the exec_shell_interact (alias exec_interact) tool, whose approval_requirement returns ApprovalRequirement::Auto. This overrides the default Required approval for code-executing tools, so LLM-controlled stdin is written into an already-approved long-running interactive shell (e.g., a python3 -i REPL, mysql, ssh, or sudo -i session) without any approval prompt. An attacker who can inject instructions via untrusted content the agent ingests (a fetched page, MCP result, or repo file) can cause commands to run at the privilege level of that approved process. Fixed in codewhale / codewhale-tui 0.8.64; the deprecated deepseek-tui crate has no fixed release.
Weakness: CWE-269
Which versions are affected by CVE-2026-75857?
8 open source packages ship an affected version, including codewhale-tui, deepseek-tui and codewhale.
| Package | Affected | Fixed in |
|---|---|---|
codewhale-tui crates.io | From 0.8.41 | 0.8.64 |
codewhale-tui crates.io | From 0.8.41 | 0.8.64 |
deepseek-tui crates.io | From 0.3.10 to 0.8.41 | None |
deepseek-tui crates.io | From 0.3.10 to 0.8.41 | None |
codewhale npm | From 0.8.41 | 0.8.64 |
codewhale npm | From 0.8.41 | 0.8.64 |
2 more packages
deepseek-tui npm | From 0.3.10 | 0.8.41 |
deepseek-tui npm | From 0.3.10 | 0.8.41 |
How do I fix CVE-2026-75857?
Upgrade codewhale-tui to 0.8.64 or later.
Is CVE-2026-75857 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-75857 exists.
Sources
Also known as GHSA-g29h-pfmp-qp9r.